Webview showing as not found

Question:
I was following Free Code Camp CSS tutorial. Initially webview was working fine. But then I created few folders and arranged the html/css files, that resulted in not working the webview. Now I removed the folders and got the files to original state, but still the webview is not working for me. Appreciate any insights from you all !

Repl link:
https://replit.com/@marianrda/htmltutorial#index.html
https://replit.com/@marianrda/htmltutorial#style.css

code snippet


Well that one is bugged, note that the url is /srcdoc instead of /. If you remove the srcdoc and hit enter, does it change?

2 Likes

well maybe it is because the server haven’t started yet, press the green run button on top and try again?

HTML/CSS/JS repls don’t “start” like a normal repl does, IIRC that button does nothing but open the webview tab there.

1 Like

I pressed the run but still the problem persist.

This caught my eye too, I’ve tried removing /srcdoc but still no difference in outcome.


thanks for the pointer.

That’s because you now renamed your HTML file. Try renaming it back to index.html, as that is the name the program needs to run the repl.

2 Likes

Please share a script reference since the error could be there also

1 Like

That’s not relevant to the issue at hand here.

1 Like