Webview display blank, wv-settings button broken

Problem description:
Html webview contains only blank and settings button in webview does not work on my iPhone. Custom domain and external page links work fine.
On a different phone (Samsung) everything works as it should, but I can‘t use that much…

Expected behavior:
Should just display my html page and let me access the settings.

Actual behavior:
Only displays blank and doesn‘t let me access the settings.

Steps to reproduce:
None, it just suddenly broke after I tried to run a code I hadn‘t tested for a while (might have contained references to no-longer-valid variables). Especially not reproducable since it‘s only on my iPhone…

Bug appears at this link:
Every single webview for every html repl I have. But I was here when it started: https://replit.com/@Elus/Snap#index.html

Browser/OS/Device:
Chrome, Safari, and the new Mobile App for iOS on my iPhone 12

Screenshot:

I’m unable to reproduce on my iPhone 14 on web. Are you still facing this issue?

Yes, it is still behaving as described in the post above.

I‘m fairly certain that it is caused by some cached data on my iPhone breaking the webview while it loads that also causes the settings button to not function. At least that‘s the only explanation I found why it would be broken on Chrome, Safari, and the mobile app, but only on this iPhone (since I didn‘t see others report this bug).

But I already deleted (to my knowledge) all cached data related to replit from safari, so it should‘ve been fixed if that is the cause, but it‘s still broken…

Maybe there‘s just more data stored somewhere else, but I wouldn’t know about that. Or the issue lies somewhere completely different…

Is the default browser on your device Chrome or Safari? Have you tried changing it up?

The standard browser was Chrome. I just switched over to Safari and it’s still the same problem.

We’re going to escalate to senior engineers and see what could be causing this. So sorry about the issues.

We haven’t been able to reproduce this issue since we don’t have some of our debugging tools on the mobile app yet @Elus

If you’re still experiencing this issue, can you report this bug through the iOS app by shaking your phone? There are some logs that get sent over when you report through the app that may help us in figuring out what’s going on.

1 Like

Website loads fine for me

I had already used the iOS mobile apps feedback function to send a bug report about this, including the screenshot and effectively the same description, about a day before I first posted this bug report here (roughly 16 days ago).

I also sent a bug report as a reply to an older bug report in hopes of reaching someone, but that email address does not seem to be in use anymore (at least the format makes it appear to be a single use and cause I didn‘t get a reply).

Also, as I said, the bug affects all browsers on my specific device, including Safari for iOS, Chrome for iOS, and the mobile app, while with a different device (Samsung Galaxy S7) everything works as normal.

That leads me to believe that the problem may be related to some data the settings rely on being cached, but having been corrupted somehow. It would explain the settings malfunctioning solely when using this specific device.

Yes, the website loads fine for me, too.
The Webview, however, does not.

But that would likely also load fine for you, given that this particular problem is likely limited to the specific device I am currently using, since a different device I tried to reproduce this on did not exhibit this same problem.

@Elus We have found relevant errors in the logs of the mobile. I have escalated this to the team and we’ll follow up as soon as I can.

1 Like

Did the team manage to find some way to solve it? It‘s been over a month now that I can‘t use replit.

I haven’t seen any new updates on the ticket, so I’ve prompted the team for an update. I’ll follow up as soon as I know more.

I am experiencing the same issue. I am using chrome on Windows. @ShaneAtReplit

@Elus Do you have the most up-to-date version of the app? We have recently released a few fixes and want to see if the issue is still occuring

1 Like

What do you see when you go to https://replco.shaneatreplit.repl.co?

1 Like

When you shake your phone, it opens support? That’s so cool!

1 Like

I have the latest version.
It still does not work.

I‘m also pretty sure that updating the app in any way can not affect a bug that also breaks the replit website‘s Webview on Safari and Chrome.
It may fix it in the app.
However, as I wrote before, I‘m fairly certain this behaviour is linked between those three, likely stemming from some data in some file they all access breaking the Webview when it loads.

Just in case this helps:

1 Like

So… has any progress been made? It‘s been 3 months now that I can‘t use replit at all.