Web view not appearing

Hi replit Support,

I have a problem that the web view does not appear in my tools on the site. I want a solution as soon as possible

best regards,
yousef

1 Like

Hi there! Are you sure you are using the correct language?

7 Likes

yes i sure i use java script

1 Like

Please post the link to your repl.
Remember that by default, when your Repl exposes an HTTP server, the Webview will automatically open.

7 Likes

Hey @dsgdsgdsgdsgsdg!

Can you please send me the link to your Repl so I can take a look?

2 Likes

In case the webview tab still doesn’t open, you can find a ‘tools’ section on the bottom-left of the IDE. If you scroll down, you should see a ‘webview’ button. Click it to open it.
image

4 Likes

Here is the problem. I am talking about this place to try to bring open the web view, but I did not find it

Well there is no problem

Do you mean you can’t find the ‘tools’ section or the ‘webview’ button itself?

1 Like

Aghhh XD.

Can you try searching for webview? Just open a new tab and type it in like this:


I hope this helps you! :smiley:

PS: It would be really helpful if you sent us the link to the repl!

4 Likes

Give me you name in discord

i send your screenshot

Hi there! I don’t use or support Discord. Can you please just send the link or screenshot?

3 Likes

Oh, are you using Node.js? Have you started a webserver, then?

Not everyone has Discord. Please keep discussions on Ask instead of moving to a different platform.

You can send screenshots here.

3 Likes

what if there is no webview under tool section. Nothing shows up when i search for webview

Can you send the link to your Repl?

1 Like