VNC Output Window not Connecting

Ran the default main.py that comes with Python(turtle), output screen is stuck on loading. Anyone else experience this?
Tried reseting browser cache and enabling cookies but can’t seem to fix the bug.

Hi, @KimDang5!

I was facing this issue a while back. Could you open your Repl’s cover page and try to run it from there? If an error is occurring, it will show on the cover page.

To open the cover page, simply add ?v=1 to your Repl URL.

Hi, @ bobastley

Thanks for the suggestion. It still doesn’t seem to work.

1 Like

Sorry to hear that. Are you using a managed device, that might be blocking a Replit domain (ex: repl.co)?

1 Like

I’m not using repl.co.
I disconnected from my wifi and connected to my hotspot and was able to run my turtle script.
Have you ever experience this issue?

1 Like

Yes, I experienced it after it suddenly stopped working one day, but I was using a managed device that was blocking repl.co, which I guess is used for displaying output. Sorry I wasn’t able to solve this, I’m not very experienced with networking and such.

2 Likes

Thanks for all your help though!

1 Like

You could try forking the repl? (Wow, this is my stock answer for every question!)

I’m experiencing this issue as well across two different repls. Any luck fixing?

Hi everyone,

Sorry I didn’t mention this earlier, but I sent a message to @IanAtCSTeach, who had forwarded the issue with Webviews to the team for investigation. He mentioned that the Output issue was probably similar to the Webview issue and I think he joined it along.

1 Like

Hi @newmediamavs support staff are investigating but if you could add your affected Repl URLs here it would be much appreciated. Thanks!

2 Likes

Hi @IanAtCSTeach , all my repls are affected when I’m connected to my home WiFi. This issue started happening this year. I’m only able to view the output panel if I’m connected to LTE.

Projects affected: https://replit.com/@KimDang5

On both my Macbook and PC, it gives me an invalid response on Webview. I even tried different browsers (Safari and Microsoft Edge). And it still says invalid response.

" 6f65ffbf-8af5-4c39-9d76-4600b3e2931c.id.repl.co sent an invalid response." is what it says. I am able to see the web view if I open in a new tab, but tbh it’s getting annoying to do that with every change/line I do.

So my output screen is just stuck on loading, but only at my house. When I am at school it loads. I tried switching browsers, restarting internet, but nothing works. Any fix?

Bug description:
Both the output tab and webview tab are not working (.py and .html). I am able to see the HTML file when I click “open in new tab” but this is not an option for my .py project.

Expected vs Current Behavior:
Expected behavior is for the output to be showing on the respective tab when running the code. Current behavior is perpetual loading or error message

Steps to reproduce:
clicking “run”

Bug appears at this link:
https://replit.com/@WilsonLee8/Project-0-Meet-the-Turtle?v=1
https://replit.com/@WilsonLee8/Learning-HTML-and-CSS-by-building-a-90s-inspired-website?v=1

Screenshot(s)/Screen Recording:


Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@WilsonLee8

Hello, we’re aware of this issue. There’s an odd network bug that is happening at the moment. If you can connect to another network, like a phone hotspot, please let us know if that resolves the issue.

UPDATE:

We have shipped a fix, please let us know if you are still having problems viewing the output window. And if you are, let us know if you’re using the webview or a python output.

I am still not able to view the output window.
image
It is a pygame repl (actually multiple pygame repls)

1 Like

Can you clear your cache on your browser and try again? And if that doesn’t work, does this still happen if you connect to another network like your phone hotspot?

1 Like

Problem description: Sometime yesterday evening, I started seeing “There was an error connecting to the server” with a “Try again” button on the output window. It’s still there this morning.

Expected behavior: Output window connects and shows me my PyGame files when running.

Actual behavior: Output window does not connect, displaying the above error when running. Clicking Try Again does not fix the issue.

Steps to reproduce: Open Repl that has PGZero and Pygame installed in it. Hit Run.

Bug appears at this link: https://replit.com/@MrRivard/PGZero-Test-Bed#main.py

Browser/OS/Device: Chrome/Windows 11/Multiple different computers

Image:

I have tried kill -1 in the shell as well to no avail.