Uploading Repl to Github to better Collaborate

Hello! I’ve recently created a Repository so my friend and I could better edit our Repl project instead of collaborating inside of Replit. However, I am a bit lost on uploading the Repl’s content inside of GitHub. I tried downloading the project and individually importing files from the project’s folder into GitHub, but the files are too big. My next reflex was to link Replit and GitHub to attempt to push the changes and all of the content into the Repository. But it gives me the following error, as seen in the picture. I’d appreciate all the help, cheers!


It gives me this error, whenever I try to push the changes. No matter what I try, fetching, pulling, etc. I’ve tried everythign and it still gives me that error, like fetching before pulling, uninstalling then reinstalling, and much more.

Ah, I see your problem. The reason this is not working is because your GitHub repository has files/changes that your active local git repository does not. It’s possible that others have commited to the repository that you have not downloaded on your machine. Here’s how to fix it:

  1. try git pull in your terminal
  2. If it doesnt work, just copy your files, re-clone the repository, and paste your changes, and then push.

It may be a bit complicated, but it seems to work for me when this happens.

If anything doesn’t work, just ask! We’ll get there in the end.

Happy coding!

Edit: You could also just copy/paste your Replit changes into github

Hello, this is the same person but on a different account. Whenever I attempt to git pull, I receive the following message: Your configuration specifies to merge with the ref 'refs/heads/main' from the remote, but no such ref was fetched.

Unfortunately, I am unable to insert me files in the GitHub Repo as they are too large, even if I try to do it individually.

Hm. Never seen that before… i dont know. Ill try to look into it