Upload File and Upload Folder has stopped working

Problem description:
Inside a replit, I am trying to upload a file. I have tried on both Chrome and Firefox. This was working fine until recently.

Expected behavior:
A window to select a file to upload.

Actual behavior:
Nothing happens.

Steps to reproduce:
Tried new replits, different browsers. Same result.

Bug appears at this link:

Google Chrome, Firefox

1 Like

Welcome to the community, @rmerrick!!! If you just click on a file or click on the folder section then click upload file, it should work. :slight_smile:

If you are still experiencing this issue, please let me know! Also, if you could provide a screenshot, it would be really helpful!

1 Like

still i cant upload file

can u send me screenshot pls

1 Like

Hi. Here is a screen shot. Once I click Upload File or Upload Folder, the option list just closes and nothing else happens. Open pane, Download as zip and Show hidden files works fine.


Perhaps it is not Replit but your OS. The popup window is provided by your OS. Does Windows need an update? Is Windows working fine otherwise? Did this problem start after you updated Windows? I find that Windows is always breaking things.

i have the same problem! but I’ve used my replit on multiple different devices and the problem persists!

I have the same issue, click on upload nothing happens. Tried different browser, new project etc but nothing seems to work.

I have the same problem. It was working 48 hours ago, now upload file does not work. Does not work after reboot, browser change, logout, login, etc. Just happened and now has persisted for about 48 hours, I can’t get work done. Also, I have noticed that this happens over the last few weeks if you leave replit open for a while, come back and try to work, you have to log out and back in THEN it works, so it seemed like it was “failing” slowly, but now, just won’t work at all.

This is a BIG problem. Needs to be addressed ASAP. This is the #1 reason I use and pay for replit is to be able to upload my files and work.

Thanks –

same for me, upload button is not working.

I have the same problem, upload button does not work

upload file isn’t working for me as well , is there any solution

I thought it might be a windows problem, but it looks like it is the same problem on my student who is using a Mac. A work around is to drag and drop files directly.

Since I posted that I have found at least 5 other topics all with the same issue. It’s a Replit bug.

go here: File Upload Not Working Solution - Replit Help - Replit Ask

1 Like

We’re looking into this issue now.