Update poetry failed with invalid poetry configuration error message

Question:
I have imported my Python project from GitHub. I need to update poetry. I receive an error message that my poetry configuration is invalid.
Repl link:
https://replit.com/@BehzadSamadi/SoNeDa

Open a shell and run:

pip install poetry==1.3.0