Unusual "no module named numpy"

Question:

import numpy as np
import matplotlib.pyplot as plt
import csv

That’s the start of the code. As soon as I try to run it it immediateky exits with the error message stated in the title. Really not sure how to resolve this, normally i never have to pip install anything on replit and certainly not numpy but thats the suggestion im getting from google

Current behavior:

Desired behavior

Repl link:

code snippet

Have you tried running poetry add numpy or pip install numpy in the Shell?

2 Likes

Hi, yes that seems to have worked when i type it into the shell, so thank you! Hwever im confused as to why i have to do this when normally its never required

You probably have guessImports turned off in your .replit file.
Click the 3 dots to view hidden files, then “Show hidden files”, then follow the instructions in the Replit Docs to change your settings.
image

2 Likes

isn’t that configuration outdated?

1 Like

I keep guessImports off because it interferes with other files and directories, sometimes packages as well. For example, if I have a folder named utils with files such as hex.py and sql.py, attempting to call them utils.hex won’t work because it automatically tries to install a related package, which becomes quite annoying.

2 Likes

yeah

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.