Unstable packages not properly updated (bun)

Question: How can I obtain unstable packages that are updated using replit?

Repl link/Link to where the bug appears: Create a blank repl and change the channel to unstable, then try to install bun. It will not have the properly updated version

Screenshots, links, or other helpful context:

Hi @JarzaClay , welcome to the forums!
Why do you use the Nix package? Replit has the official Bun template to use.
Hope this helps!

2 Likes

Hello Nate!
The reason for this is because the replit template is also out of date, unfortunately. I don’t know if there is a way to update bun in that template.

Maybe try typing npm update bun in the Shell?

2 Likes

@JarzaClay Or go to the tool System Dependencies (Tools > System Dependencies). Search ‘Bun’ and use it? Do this in the Bun repl or a blank one. I suggest the Bun repl.

1 Like

I figured out it’s not a problem from replit, but the npm package is out of date. Thank you so much for the help! <3

image

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.