UNKOWN_NOT_GIT - Unable to restore venv from replit git

Problem description:
I created a new branch to experiment with my repo. I removed the venv folder then tried to restore it and it fails with UNKOWN_NOT_GIT every time. The repo isn’t linked to a GitHub webserver. I just created a Replit Git branch.

Expected behavior:
I should be able to restore all of the files without erroring out.

Actual behavior:
UNKOWN_NOT_GIT error when trying to restore the files

Switching back to the main branch doesn’t restore the venv files that were removed.

Steps to reproduce:
1.) Fork the Embedchain bot https://replit.com/@anshul/Embedchain-Chat-Bot?v=1
2.) Run by hitting the run button and let Replit build the environment
3.) Navigate to “git” tab in Replit and create a new branch named “abc”
4.) Select branch “abc”
5.) Hit Run to make sure the app runs
6.) Remove the “venv” folder then wait a min or two
7.) In the git tab, hit restore

Browser: Safari Version 16.5.1 (18615.
OS: MacOS Ventura 13.4.1 (22F82)
Device: M2 Air

Also reproduces on other Apple devices and is independent of the OS and browser.

Hey @RayFernando!

If you use git in the shell to perform the restoration of the venv folder manually, does work?


That worked! For those looking to solve this I did the following:

1.) Go to the shell tab and make sure you are in the root of your project ~/
2.) Run the following command git restore .
3.) ???
4.) Profit


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.