Unable to view app in webview

Bug description:
My webview says " The webpage at <xyz_app_url_that_i_cannot_include_because_there_is_a_limit_on_the_number_of_urls_i_can_include_in_a_post_for_no_reason> might be temporarily down or it may have moved permanently to a new web address."

Expected vs Current Behavior:
I can see my app

Steps to reproduce:
Just open the webview. Additional Context: I created this app at a coffee shop where it was working ok. When I got home this error started popping up. I’ve tried the supposed fixes in

But that doesn’t help at all.

Bug appears at this link: https://replit.com/@mikegottlieb/AccountOnboarder

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/121.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@mikegottlieb

Here are some of the other URLs I wanted to include in the post but couldn’t because there is some ridiculous 2 url limit in place on forum posts.

The error URL: https://e3bfbde3-9a1e-4242-85d8-30ee283117fd-00-3bnu3lrtazqax.janeway.replit.dev/__replco/devtools_wrapper.html?initialPath=%2F&id=%3Ar2n%3A

The other forum topic with not helpful solution: Help Fixing WebView output - Connection was reset

@SuzyAtReplit Here is my new post as requested

Thanks @mikegottlieb. That’s interesting that it was working in the coffee shop. Were you using their network when it was working? Any other differences you can think of at the coffee shop?

I forked it and here’s what it looks like for me on my home network:

1 Like

Yes I was on their wifi and also connected to the same VPN connection that I am connected to at home.

I have tried turning that VPN on/off, but no luck. I also changed my home DNS to Cloudflare and no luck.

Ok, now it works… I have no reasonable explanation as to why. Maybe you loading it up poked it in the right way? ¯_(ツ)_/¯

@mikegottlieb Yeah, that was us! We were working on a mitigation specific to what you mentioned here (with the error link so thanks for providing those details) and we just flipped the flag for your user.

I was just about to tell you to test again. Thanks for the confirmation!

2 Likes

Sounds good. Thanks for resolving this!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.