Unable to update "rubygems-update" version

Bug description:
I am using the Replit Rails template. I want to add a gem called “y-rb”, but the version of rubygems that y-rb requires is greater than the version supported in the replit template. I have tried many times, but have been unable to get rubygems to update from versoin 3.2.26 to the latest 3.4.13.

Expected vs Current Behavior:
I expect to be able to add the following to my gemfile:
gem 'rubygems-update', '~> 3.4', '>= 3.4.13'
then run “bundle update” in my shell and have rubygems update to 3.4.13

Steps to reproduce:
Try running “bundle update rubygems-update” in the shell of the Replit Ruby on Rails template repl and it will produce the following error:
“Bundler attempted to update rubygems-update but its version stayed the same”

Bug appears at this link: https://replit.com/@TeamLetham01/Test#main.rb

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36 OPR/99.0.0.0

Replit Profile: https://replit.com/@lmletham