Question: I am working on project “mean-variance-standarad-deviation-calculator” which I have developed successfully and is ready to test. Right now I am unable to type any thing in console. When I press “Run” button it give me message
sh: line 1: use: command not found
I have installed
numpy successfully. But I have python compatibility issue. I receive following message when I tried to install python.
poetry add 'replit 3.3.2' Updating dependencies Resolving dependencies... The current project's Python requirement (>=3.8,<4.0) is not compatible with some of the required packages Python requirement: - replit requires Python >=3.9,<4.0, so it will not be satisfied for Python >=3.8,<3.9 Because fcc-mean-var-std depends on replit (3.3.2) which requires Python >=3.9,<4.0, version solving failed. • Check your dependencies Python requirement: The Python requirement can be specified via the `python` or `markers` properties For replit, a possible solution would be to set the `python` property to ">=3.9,<4.0" https://python-poetry.org/docs/dependency-specification/#python-restricted-dependencies, https://python-poetry.org/docs/dependency-specification/#using-environment-markers exit status 1
In pyproject.toml file I changed the python version from
python-versions = "^3.9"
now I need to update pyproject file but I am unable to type in my console.
Hope to receive an early reply.
Replit Profile: https://replit.com/@SuhailAsghar