Unable to type in console

Question: I am working on project “mean-variance-standarad-deviation-calculator” which I have developed successfully and is ready to test. Right now I am unable to type any thing in console. When I press “Run” button it give me message sh: line 1: use: command not found
I have installed numpy successfully. But I have python compatibility issue. I receive following message when I tried to install python.

poetry add 'replit 3.3.2'

Updating dependencies
Resolving dependencies...

The current project's Python requirement (>=3.8,<4.0) is not compatible with some of the required packages Python requirement:
  - replit requires Python >=3.9,<4.0, so it will not be satisfied for Python >=3.8,<3.9

Because fcc-mean-var-std depends on replit (3.3.2) which requires Python >=3.9,<4.0, version solving failed.

  • Check your dependencies Python requirement: The Python requirement can be specified via the `python` or `markers` properties
    For replit, a possible solution would be to set the `python` property to ">=3.9,<4.0"

exit status 1

In pyproject.toml file I changed the python version from 3.8 to 3.9 as
python-versions = "^3.9"
now I need to update pyproject file but I am unable to type in my console.
Hope to receive an early reply.

Replit Profile: https://replit.com/@SuhailAsghar

There seems to be a few issues here, I’ll try to hit all of them:

Could you share the contents of your .replit file? Seems like it was messed up.

Do you need the replit package? If not, then you should be safe to remove it.

This is a newer change to how the Console works, try using the Shell instead.

Thanks for your quick reply. Below is link of my .replit file

Try changing line 4 (run = "use run command") to this:

run = "python3 main.py"

Thanks a lot for your help. console is working now. I have one more issue regarding my programming code.

I am working on project mean-variance-standard-deviation-calculator . It accepts a nine digits list as parameter
and returns dictionary of mean-variance-standard-deviation values.If we pass a list less than nine digits then it raises
ValueError message. It works perfectly and calculates all the values and returns dictionary as I have mentioned above.
But when I test it with test_module.py (which tests the program with three examples) it passes first two tests and failed
in the thrid test. Following is the output and message it gives after I run the program.Can you write me what error my code have.
I have checked it carefully but could not find any issue which causes the failure of third test.
here is my code link

Output of my progam after I run it against test_module.py

{'mean': [[3.0, 4.0, 5.0], [1.0, 4.0, 7.0], 4.0], 
'variance': [[6.0, 6.0, 6.0], [0.6666666666666666, 0.6666666666666666, 0.6666666666666666], 6.666666666666667], 
'standard deviation': [[2.449489742783178, 2.449489742783178, 2.449489742783178], [0.816496580927726, 0.816496580927726, 0.816496580927726], 2.581988897471611], 
'max': [[6, 7, 8], [2, 5, 8], 8], 'min': [[0, 1, 2], [0, 3, 6], 0], 'sum': [[9, 12, 15], [3, 12, 21], 36]}
..List must contains nine numbers
FAIL: test_calculate_with_few_digits (test_module.UnitTests)

Traceback (most recent call last):
   File "/home/runner/boilerplate-mean-variance-standard-deviation-calculator/test_module.py", 
line 53, in test_calculate_with_few_digits
   self.assertRaisesRegex(ValueError, "List must contain nine numbers.",
AssertionError: ValueError not raised by calculate

Ran 3 tests in 0.002s
FAILED (failures=1)