Unable To Run Repl

You can’t run this Repl right now.

This Repl is unavailable at the moment.

If you are the owner of this Repl and believe you should be able to run it, please contact support.

每当在 Shell 运行“wget”命令时,Repl 无法运行并出现此提示。
Repl couldn’t run and the prompt appears whenever the “wget” command is run in the Shell Console.

Welcome to the community, @Coriginbe!

This is a common issue that a lot of people are experiencing and get reported. This is because of a connection or loading issue with the machine your Repl is on.

Usually, you can wait for the machine to resolve the issues itself, but it can take some time depending on the intensity of the problem.

To workaround it, you can fork the Repl. This will create a new copy of your Repl onto a new machine, which should not have any problems.

Alternatively, you can type $ kill 1 into the shell to forcibly restart the Repl. However, this method only works if the message appears in your console/webview.


一段时间后 Repl 可以被再次访问。但当我再次使用“wget”命令,问题会再次发生。
Repl can be run again after a while. But when I use the “wget” command again, the problem happens again.

You are probably doing something that the machine can’t do/handle. That could be downloading a file that is corrupted/has a very huge file size or you are using an api that isn’t allowed to be used on the machine.

So to be safe, it will not open the Repl until it can resolve the issue.


What can’t machines do/handle? And what is the file size of a file that is “very huge”?

The machine that is running your Repl isn’t a normal computer like the one you are using right now; it is used to just run your code from your computer.

If it is downloading a malicious file that can do stuff on the terminal, it can just run other applications that it is not supposed to and it may either not have enough resources or just crash and reboot. This is why it is not able to run your Repl.

1 Like

GitHub - alist-org/alist: 🗂️A file list program that supports multiple storage, powered by Gin and Solidjs. / 一个支持多存储的文件列表程序,使用 Gin 和 Solidjs。

Do you know about the AList Project? Could Repl run it?

It seems to be using a exe file. So I don’t think it’s possible it will run it in a Repl

1 Like

I can run it just a week ago, why’s that?

it may just be a fluke. or you could have used a different wget command

1 Like

I have it working here. I had to run in shell:

curl -L https://github.com/alist-org/alist/releases/latest/download/alist-linux-amd64.tar.gz -o /dev/shm/alist.tar.gz
tar -zxvf /dev/shm/alist.tar.gz
./alist server
1 Like

I found the problem. When I run the command with a Personal Repl, neither my method nor yours no longer has the previous problem; but when I run with Team Repl, it gets the same issue.