Unable to query pinecone

Bug description:
Whenever trying to connect to pinecone, I get the following error:
SSLError(SSLZeroReturnError(6, ‘TLS/SSL connection has been closed (EOF) (_ssl.c:997)’)))

Expected vs Current Behavior:
urllib3.exceptions.MaxRetryError: HTTPSConnectionPool(host=‘suite-code-repo-unknown.svc.us-west1-gcp.pinecone.io’, port=443): Max retries exceeded with url: /query (Caused by SSLError(SSLZeroReturnError(6, ‘TLS/SSL connection has been closed (EOF) (_ssl.c:997)’)))

Steps to reproduce:
I create a fresh replit and tried to connect to query pinecone and got the error.

Bug appears at this link: https://replit.com/@MasonSwofford/law#main.py

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.0.0 Safari/537.36

Found the issue. Please close this.

Hi! Glad you solved the problem. Could you please edit your post to include how you fixed it? It can help others find a solution if they are facing a similar issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.