Unable to install Pillow / forked replit isnt fully duplicating

I am forking this replit for my APCSP class but when I run the code on the forked version, it says

Traceback (most recent call last):
  File "main.py", line 13, in <module>
    from PIL import Image #from PIL import Image 
ModuleNotFoundError: No module named 'PIL'

I tried to install pillow using the package manager but then I get this error:

Replit: Updating package configuration

--> poetry add 'Pillow 9.5.0'
exec: "poetry": executable file not found in $PATH

Replit: Package operation failed.

If I try to do pip install Pillow I then get THIS error

/nix/store/abvijrl56pyn7bvfggj6nlzrwz7l912a-nix-index-0.1.2/bin/nix-locate: /nix/store/s9qbqh7gzacs7h68b2jfmn9l6q4jwfjz-glibc-2.33-59/lib/libc.so.6: version `GLIBC_2.34' not found (required by /nix/store/mdck89nsfisflwjv6xv8ydj7dj0sj2pn-gcc-11.3.0-lib/lib/libgcc_s.so.1)
bash: pip: command not found

I am at a complete loss of what to do, I have a requirement.txt file with “pillow” in it, I have deleted and reforked the project multiple times, and I’ve had this issue on two different devices, one mac and one windows pc. Any help would be appreciated. Here is my project