Unable to import repo from gitHub

Hi all!
I am unable to reproduce this bug: I can import repos just fine on Replit.

1 Like

@Quantaindew, @huywallz, and @SnowflakeFlake:

Could you please provide a link to repo(s) you’re trying to import so we can see if the issue is limited to a few repos?

2 Likes
1 Like

Try the one I’m trying to import

1 Like

@jesse
here’s a drive link to the videos of me opening the repl
I made the repl by using the import from github option
Nothing else has been changed, I’ve tried this multiple times and this has been an issue everytime

1 Like

@Firepup650

1 Like

According to Replit staff this is due to this issue:

Github claims the issue is resolved. Please try again.

1 Like

I have combined some reports. Some may be from the github incident, and some may be from another root cause with our repo import tool.

Please post again if you are still having issues with github imports with the bug form:
Problem description:

Expected behavior:

Actual behavior:

Steps to reproduce:

2 Likes

Replit stuck on importing the github repository from thefreecodecamp

it just the boilerplate, I have 100mpbs network speed.

its been an hour

2 Likes

Hi, new user here and am still having this issue. I have the same issue as John-teology above. Replit gets stuck on “importing…” when importing one of the boilerplate repositories from free code camp. I have attempted to reimport the repository several times

Environment
Google Chrome - Windows 10
Good enough connection strength
Issue is consistently reproducible
Repository uses python

Link
https://replit.com/github/freeCodeCamp/boilerplate-arithmetic-formatter
This is the repository that is having issues

Steps to reproduce

  1. Using the link, import the repository from Github
  2. The repository will become stuck on Importing…

Expected Behaviour
The repository should not be stuck on importing…

Actual Behaviour
Replit becomes stuck on Importing… and the repository cannot be accessed

Visual Proof of Bug

2 Likes

Hi everyone, I am also having this issue with my repo.

I tried importing this repo but im also stilkl stuck with “importing”

I hope this gets resolved soon! thank you!

2 Likes

So in the console in your screenshot I can see that you’re getting a 409 status code for the get_connection_metadata API request. Maybe that’s something that could help admins find the root of the issue? And could you share the response of that request (watch out not to leak any sensitive info) so that we can know exactly what’s happening?

1 Like

when i importing a repository from github it is not imported and take a lot of time

1 Like

Hi @AlokShukla6 , welcome to the forums!
This is a known bug that has been reported before, and the team is (hopefully) working on it!

2 Likes

So how can I fix now

It will take a while, do be patient. We are waiting for the news from the team.

2 Likes

Github repo not getting imported.

Tried creating a new Repl, re-installing Github connect with Replit, new GitHub repo, etc as mentioned here previously). Did not help fix the issue.
Other info: Hacker Plan
8x boosted used

Any help is appreciated :pray:

1 Like

This is a known issue originally attributed to a bug on Github’s end but Github resolved that issue so I don’t think anyone knows why it’s happening anymore.

2 Likes

Question:
Github import function is not working on my end. It just keep on showing the spinning animation (loading) and the mouse pointer is disabled or not allowed. May I ask for assistance on this matter. Similar issue is not very clear on how it was resolved.

Replit Profile: https://replit.com/@SolveLearnRepeat888

1 Like

This seems to be an issue on Replit’s end: https://status.replit.com/notices/0xcrqboh4k1zbqyi-some-github-repositories-cannot-be-imported

1 Like