Unable to clone repository

Unable to clone github repositories. Option not available.


I’ve tried deleting cookies and data, using a different browser, even using Tor, but nothing solves the issue.

Hi @Soulsender welcome to the community!

Can you please share the Github URL you wish to import?

Well the thing is that I cannot import ANY github project, as you can see there is no option to.

I tried revoking replit access on Github, and re-adding it, but I think the error might be connected to my github account.

In any case, the repository I wanted to clone was GitHub - CryptexProject/Earth-Invader: Discord bot using the cryptography toolkit of Cryptex

Hi @Soulsender thank you for sharing the link to the github url.

I just tested creating a new Repl and then clicked GitHub Import (top right of window). It worked first time.

If it helps please fork Earth-Invader - Replit

I’ll make a quick GIF of the steps now to see if this helps you resolve your issue.


Can you please try to replicate the above steps and let me know if this resolves your issue? If not please describe any differences.

Yes I’ve followed those exact steps, but when I sign into my github account and connect it to replit, there is no URL bar to input the repository’s location.

Changing the privacy from Public to Private does nothing. Signing out and signing back in does nothing.

I tried making another Replit account, and the URL bar appears for that - UNTIL I sign into github. At which point it disappears.

These are the permissions Replit has on my Github account.

Have you tried on different browsers it may be issue with cache.
Try updating to latest version.
Also Chek github permissions in github account.

1 Like

To add on make sure your GH account is linked (on Replit)¹. And try clearing your cookies.

¹ Log In - Replit

Yes I tried with Chromium as well, you can see my github permissions in the attached above image. I am on Firefox 103.0.1.

I’ve already tried clearing the browser cache and cookies, and using a different browser. Neither work. My Replit account is connected via github as well.

Looks like a bug then. You can file a bug report.

@Soulsender You can try going to this link:

If that doesn’t work, you can create a Blank Repl and run the following command in the shell:

git clone https://github.com/CryptexProject/Earth-Invader

You’ll then need to setup the repl which you can do by modifying the replit.nix and .replit files. You’ll have to show hidden files to see these.

Check out the documentation for more info:

instead of creating a blank repl and configuring it, you could just create a new python repl and run in it:

git clone https://github.com/CryptexProject/Earth-Invader
mv Earth-Invader/* Earth-Invader/.* .
rm -rf Earth-Invader
1 Like