Typing_extensions version conflict

So I’ve already seen posts about version conflict between typing_extensions required by replit and by third-party libraries, suggesting that this is a long-standing issue. My experience was similar: I needed to install streamlit 1.25.0 that requires typing-extensions (>=4.1.0,<5), which conflicts with replit 3.3.1 that requires typing_extensions (>=3.7.4,<4.0.0). Since I was not able to address this conflict, I had to use another IDE instead, which wasn’t as convenient as Replit.

Any tips for installing streamlit despite the version conflict? Also when will Replit update their dependency?

run in Shell

pip install -U poetry
poetry add -v git+https://github.com/noneofyourbusiness1415252/replit-py

not sure. It’s almost been a year


Have you looked into our Streamlit template?

This should be a better starting point than installing Streamit into a python Repl.


Thank you! I just tried it and it works like a charm

Thanks! I actually came across your answer yesterday and tried running this command, but got an error saying " [Errno 13] Permission denied: ‘/nix/store/xf54733x4chbawkh1qvy9i1i4mlscy1c-python3-3.10.11/src’". Will try again today

Do you happen to be using the Python template or something else (please specify)?

Yep I was using the Python template

(Tried again today and it reported the same error)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.