Trouble with NumPy package - Module not found Error

Hello everyone,

I’m new to the game and started following the “Replit Beginner Tutorials”, currently on “Lesson 3 - Managing Depencies with Replit”.

I’m following everything to the letter at this stage and am faced with a problem I can’t figure out at
“Installing the spaCy language model”.

Here’s a link to my profile: TuomasJuusti (Tuomas Juusti) - Replit (no other projects going on besides this)

And here’s a screenshot of the client with the error message:

I did a little forum search first and while I couldn’t find this exact problem elsewhere, I found that others seem to have had difficulties with installation of packages. This might be related.

Thanks in advance!

1 Like

Hi @Tuomas welcome to the community!

You are right. There seems to be an issue with Python repls at the moment. I’ve logged this with support and will let you know when I have more information.

Phew, good to hear! So it wasn’t just me :upside_down_face:

Allright, looking to hear about any updates to the situation.


Hi again @Tuomas

Could you please try creating a brand new Python repl and paste the code in again. Let me know if you see the same error message.


I created a brand new repl, and to my surprise it actually worked this time!

I wonder if this was just a blip in the machine or if someone actually updated something behind the scenes… anyway, I’m glad it worked.

Back to the lessons!

Hi @Tuomas it was a change to fix an issue with Python repls + module imports. Best of luck with your lessons!