Trouble with github sync

Problem description:
I have been struggling with getting Replit to accept my github credentials all morning. I have created an entirely new repo which looks promising but even still Replit thinks my github account is not connected. It has worked in the past. I tried disconnecting and reconnecting github via replit accounts page several times, I logged out and back in several times. I can’t get them to recognize each other.

Expected behavior:
git sync with replit and github

Actual behavior:
does not recognize me as having github

Steps to reproduce:
use git tab in repl

Browser: replit app desktop
OS: macos
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA: 1.0.5
Plan (Free, Hacker, Pro Plan): teams pro

1 Like

This can be a little tricky to troubleshoot, but in general, we’re looking to make a 1:1 connection to your GitHub and Replit using the same primary email address.

Firstly, it looks like you are using a student account. We are having some issues with student accounts at the moment (status page linked here) so you may wish to try again after they are resolved.

Additionally, student accounts tend to have limited functionality so unless you need to connect as a student for coursework, I’d recommend you create a new Replit account to ensure you have full functionality (if that’s an option at all).

Once you have your new Replit account, check that your GitHub settings to ensure your primary email on GitHub the same as your email on Replit. Additionally, there are a few different ways we can try connecting to GitHub. We can try the “connected services” route in your account:

If that doesn’t seem to work, you can try creating a new Repl and clicking “Import from GitHub”. Or on an existing Repl, you might see options if you bring up the “Git” application.

I hope the information helps. We also have some other posts like this one you can review and see troubleshooting steps taken by other users.


Thanks for the reply.

I am not using a student account. I am using a regular paid Teams Pro Account.

If I click on the above connected services link it shows that my account is indeed linked to GitHub. Also the reason I think it is a bug is because I indeed just today created a new repl and imported it directly from GitHub and this issue still exists. Maybe there is a bug with my team account not using my configured users GitHub? Whatever the issue it is very frustrating.

Hi @avataraustin !
Can you disconnect and reconnect your Github account and see if the issue persists? If so, try disconnecting on the repo’s side and see if that helps.

1 Like

Are you telling me I need to go to account settings and uninstall?

I am weary because it will probably just mess up my other repos that actually work…

What if you go to and disconnected from there, then reconnect?

I just tried that (again). It lets me disconnect from Replit/account, I refreshed the page then clicked the connect to github button, it connects and then shows github as connected in the accounts page. If I go to the repl page and view the github tab I refresh and it still says…

If I try clicking the connect button again the best I get is a never-ending “connecting” msg

It never actually connects.