Trouble installing packages in Python

Im setting up a 2nd program in python. Basically a copy of the code and packages of the 1st which I will edit - for different results. On Free version so limited CPU and RAM.

I hit Run to install the packages, and it does, but fails installing at least 1 web3.
I tried installing from /packages but tries and fails. see below.

I even set up a new free account, incase this one was capped out on something, but that failed also - just on a different package.

I have packages installed on the version 1 so stumped on what to do to troubleshoot/solve for this code.
Log says Replit depends on typing_extensions? Is this a version compatibility issue ? The other code base using Replit 3.3.1 and web3 6.6.1


--> poetry add 'web3 6.6.1'

Updating dependencies
Resolving dependencies...


  Because no versions of replit match >3.2.4,<3.2.5 || >3.2.5,<3.2.6 || >3.2.6,<3.2.7 || >3.2.7,<3.2.8 || >3.2.8,<3.3.0 || >3.3.0,<3.3.1 || >3.3.1,<4.0.0
   and replit (3.2.4) depends on typing_extensions (>=3.7.4,<4.0.0), replit (>=3.2.4,<3.2.5 || >3.2.5,<3.2.6 || >3.2.6,<3.2.7 || >3.2.7,<3.2.8 || >3.2.8,<3.3.0 || >3.3.0,<3.3.1 || >3.3.1,<4.0.0) requires typing_extensions (>=3.7.4,<4.0.0).
  And because replit (3.2.6) depends on typing_extensions (>=3.7.4,<4.0.0), replit (>=3.2.4,<3.2.5 || >3.2.5,<3.2.7 || >3.2.7,<3.2.8 || >3.2.8,<3.3.0 || >3.3.0,<3.3.1 || >3.3.1,<4.0.0) requires typing_extensions (>=3.7.4,<4.0.0).
  And because replit (3.2.7) depends on typing_extensions (>=3.7.4,<4.0.0)
   and replit (3.2.8) depends on typing_extensions (>=3.7.4,<4.0.0), replit (>=3.2.4,<3.2.5 || >3.2.5,<3.3.0 || >3.3.0,<3.3.1 || >3.3.1,<4.0.0) requires typing_extensions (>=3.7.4,<4.0.0).
  And because replit (3.3.0) depends on typing_extensions (>=3.7.4,<4.0.0)
   and replit (3.3.1) depends on typing_extensions (>=3.7.4,<4.0.0), replit (>=3.2.4,<3.2.5 || >3.2.5,<4.0.0) requires typing_extensions (>=3.7.4,<4.0.0).
  And because replit (3.2.5) depends on typing_extensions (>=3.7.4,<4.0.0)
   and web3 (6.6.1) depends on typing-extensions (>=4.0.1), web3 (6.6.1) is incompatible with replit (>=3.2.4,<4.0.0).
  So, because python-template depends on both replit (^3.2.4) and web3 (6.6.1), version solving failed.

  at venv/lib/python3.10/site-packages/poetry/puzzle/ in _solve
      237β”‚             packages = result.packages
      238β”‚         except OverrideNeeded as e:
      239β”‚             return self.solve_in_compatibility_mode(e.overrides, use_latest=use_latest)
      240β”‚         except SolveFailure as e:
    β†’ 241β”‚             raise SolverProblemError(e)
      243β”‚         results = dict(
      244β”‚             depth_first_search(
      245β”‚                 PackageNode(self._package, packages), aggregate_package_nodes
exit status 1

Replit: Package operation failed.

Hello @AdamFerguson8!

Replit should really update their package, but in the meantime, you can do this:


Thanks for this
Im pretty new with this stuff so limted to copy/paste and cross fingers for a solution.

In Shell tried the instruction
~/Crypto-Notifications-Python$ poetry add git+

but got the following error:

poetry add git+


Command β€˜[β€˜git’, β€˜config’, β€˜-l’]’ returned non-zero exit status 1.

at venv/lib/python3.10/site-packages/poetry/utils/ in run
213β”‚ process.wait()
214β”‚ raise
215β”‚ retcode = process.poll()
216β”‚ if check and retcode:
β†’ 217β”‚ raise CalledProcessError(
218β”‚ retcode, process.args, output=stdout, stderr=stderr
219β”‚ )
220β”‚ finally:
221β”‚ # None because our context manager exit does not use them.

Good news is that this seems to keep happening, so I have more steps to try:

1 Like

I too am having a problem installing SQLALchemy from the github fork.

When I run

kill 1
pip install -U poetry

I get this error

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
clikit 0.6.2 requires crashtest<0.4.0,>=0.3.0; python_version >= "3.6" and python_version < "4.0", but you have crashtest 0.4.1 which is incompatible.
Successfully installed build-0.10.0 cleo-2.0.1 crashtest-0.4.1 dulwich-0.21.5 filelock-3.12.2 importlib-metadata-6.7.0 installer-0.7.0 jaraco.classes-3.2.3 jsonschema-4.18.4 jsonschema-specifications-2023.7.1 keyring-23.13.1 more-itertools-9.1.0 platformdirs-3.8.0 poetry-1.5.1 poetry-core-1.6.1 poetry-plugin-export-1.4.0 pyproject-hooks-1.0.0 rapidfuzz-2.15.1 referencing-0.30.0 rpds-py-0.9.2 trove-classifiers-2023.7.6 virtualenv-20.23.1 zipp-3.15.0

and when I then run

poetry add -vv git+

I get this error

 β€’ Updating argon2-cffi-bindings (21.2.0 -> 21.2.0): Failed

  Stack trace:

  1  venv/lib/python3.10/site-packages/poetry/utils/ in _run
       output =


  Command '['/home/runner/images-in-a-class/venv/bin/python', '-I', '-W', 'ignore', '-']' returned non-zero exit status 1.

  at /nix/store/hd4cc9rh83j291r5539hkf6qd8lgiikb-python3-3.10.8/lib/python3.10/ in run
       522β”‚             # We don't call process.wait() as .__exit__ does that for us.
       523β”‚             raise
       524β”‚         retcode = process.poll()
       525β”‚         if check and retcode:
    β†’  526β”‚             raise CalledProcessError(retcode, process.args,
       527β”‚                                      output=stdout, stderr=stderr)
       528β”‚     return CompletedProcess(process.args, retcode, stdout, stderr)

The following error occurred when trying to handle this error:

  Stack trace:

  13  venv/lib/python3.10/site-packages/poetry/installation/ in _execute_operation
        result = self._do_execute_operation(operation)

  12  venv/lib/python3.10/site-packages/poetry/installation/ in _do_execute_operation
        result: int = getattr(self, f"_execute_{method}")(operation)

  11  venv/lib/python3.10/site-packages/poetry/installation/ in _execute_update
        status_code = self._update(operation)

  10  venv/lib/python3.10/site-packages/poetry/installation/ in _update
        return self._install(operation)

   9  venv/lib/python3.10/site-packages/poetry/installation/ in _install
        archive = self._download(operation)

   8  venv/lib/python3.10/site-packages/poetry/installation/ in _download
        link = self._chooser.choose_for(operation.package)

   7  venv/lib/python3.10/site-packages/poetry/installation/ in choose_for
        if not Wheel(link.filename).is_supported_by_environment(self._env):

   6  venv/lib/python3.10/site-packages/poetry/utils/ in is_supported_by_environment
        return bool(set(env.supported_tags).intersection(self.tags))

   5  venv/lib/python3.10/site-packages/poetry/utils/ in supported_tags
        self._supported_tags = self.get_supported_tags()

   4  venv/lib/python3.10/site-packages/poetry/utils/ in get_supported_tags
        output = self.run_python_script(GET_SYS_TAGS)

   3  venv/lib/python3.10/site-packages/poetry/utils/ in run_python_script

   2  venv/lib/python3.10/site-packages/poetry/utils/ in run
        return self._run(cmd, **kwargs)

   1  venv/lib/python3.10/site-packages/poetry/utils/ in _run
        return super()._run(cmd, **kwargs)


  Command ['/home/runner/images-in-a-class/venv/bin/python', '-I', '-W', 'ignore', '-'] errored with the following return code 1
  Error output:
  Traceback (most recent call last):
    File "<stdin>", line 18, in <module>
    File "<frozen importlib._bootstrap_external>", line 879, in exec_module
    File "<frozen importlib._bootstrap_external>", line 1016, in get_code
    File "<frozen importlib._bootstrap_external>", line 1073, in get_data
  FileNotFoundError: [Errno 2] No such file or directory: '/home/runner/images-in-a-class/venv/lib/python3.10/site-packages/packaging/'
  import importlib.util
  import json
  import sys
  from pathlib import Path
  spec = importlib.util.spec_from_file_location(
      "packaging", Path(r"/home/runner/images-in-a-class/venv/lib/python3.10/site-packages/packaging/")
  packaging = importlib.util.module_from_spec(spec)
  sys.modules[] = packaging
  spec = importlib.util.spec_from_file_location(
      "packaging.tags", Path(r"/home/runner/images-in-a-class/venv/lib/python3.10/site-packages/packaging/")
  packaging_tags = importlib.util.module_from_spec(spec)
      json.dumps([(t.interpreter, t.abi, t.platform) for t in packaging_tags.sys_tags()])

  at venv/lib/python3.10/site-packages/poetry/utils/ in _run
      1521β”‚                 output = ""
      1522β”‚             else:
      1523β”‚                 output = subprocess.check_output(cmd, stderr=stderr, env=env, **kwargs)
      1524β”‚         except CalledProcessError as e:
    β†’ 1525β”‚             raise EnvCommandError(e, input=input_)
      1527β”‚         return decode(output)
      1529β”‚     def execute(self, bin: str, *args: str, **kwargs: Any) -> int:

Has anyone got any idea what needs to be done to successfully install SQLAlchemy? I know this was working several weeks ago.