'Toggle developer tools' doesn't work

Hi
im using HTML, CSS, javascript template.
i want to use developer tools on webview.
but the button doesn’t work.
is there any solution for this?

1 Like

Hey @DongYoungSon welcome to the forums!

In the webview to the right of the URL press the wrench icon. Then that will open dev tools like the console, dom and more

1 Like

Maybe check if you have an ad blocker, and make sure that is turned off. A lot of ad blockers tend to block random Replit things every so often!

1 Like

No the button doesn’t work on linux ubuntu at all. I replied in a post but didn’t here anything back about this. This should open up what I need another console, and when I inspect the page using google console this is the error msg that greets me. I am pretty new to javascript and coding but I know an issue when I see it.

I don’t think the operating system will effect something like this.

Sometimes it doesn’t work the first couple of tries, maybe give it a minute, don’t refresh, and try again?

Yes it might not be the OS but it is not working at all, no matter how many tries there is a way around it, open up the following tab page by pressing the button next to toggle on the right and then the console still wont show up, but if you click inspect and just use google chromes console yourself it works just fine. Here is a screen shot. As you can see below where it is meant to be it is not but clicking right and inspecting with the mouse it still works. It would be nice though if someone could investigate this issue.

My suspicion would be that this is related to an ad/popup blocker as @CodingCactus suggested, I’ve tried creating a new HTML, CSS & JS Repl and the button worked fine for me, first try, no waiting… (video)

Nope because I took the add blocker off reset all default settings cleared cache and it still produced the same error. Something else is going on. It doesn’t work at all and if you have a look at first screen shot you will see devtools error msg they don’t work. Nothing related to add blocker addons. Thanks for the reply though :). I just am no sure what the fix is I cannot get this thing to work even once, no matter the setting but luckily the work around is fine and works. I am just surprised others have reported this issue as well with replit.

1 Like

I’m afraid to say, it’s definitely something on your end, I’ve just forked your Repl and it worked fine for me (video).

That is ok, I am not sure if it is because everything functions just fine on my end, google console works just fine, my git and github, my code editor all is just fine, and I have no other issues what so ever with anything. So it is a bit of a mystery, I am not surprising the repl works just fine as it was never an issue with that but I am just perplexed as to the issue it could be. Maybe the current version of chrome on linux?

1 Like

Personally, in all honesty, I find Chrome Developer tools are much better anyway. I usually have my Repl open in its own tab with the developer tools open and have Replit open in another and have half my screen one and half the other (if I’m using a smaller screened laptop I might have the editor taking up more space).

Like this:

Thanks Matt that is exactly how I run my code editor. :slight_smile:

having the same issue as constUsername

1 Like

Just use the work around, Click on (Open new tab) rather than (Toggle), once the new page is open you still wont see the dev tools or console they provide, but it’s easier to just click inspect and use Googles console.

1 Like