This Program Will Make You Mad

Ok so I spent some time making this. It uses the sus character , and many bad practices and annoying things so there you go. It’s a “Hello World!” program.

range = ["l", print, 1,   "W", 3, "e!",    staticmethod]
ඞඞඞ = range[(8 % --7)]
ඞඞඞඞ = [((range)[        20 % 7])][0]
ඞඞඞඞඞ = [  ඞඞඞ, (((ඞඞඞඞ   ).__class__))][1]
ඞඞ = (([list.index]))[0]
def ඞ(     ඞa, ඞb): ඞa.__getattribute__("pop")(ඞb)
ඞ(range, ඞඞ(range, ඞඞඞඞ))
ඞ(range, (range, (0x23 ** 0x00))[(0x23 ** 0x00)])
range.extend(               (["ord", "H "  ]))
if ඞඞඞඞඞඞ := "":
 print("dsada")
ඞඞn = ""
class console:
    @ඞඞඞඞ
    def log(*sys):
                               ඞඞඞ(*sys)
    class ඞError(Exception): pass
ඞCඞඞ = --(-(0x00 ** 0x00))
for print in (range):
    ඞCඞඞ += 0x01
    ඞඞc = ""
    class input:
         ඞ3=not(not(not(True)))
         while not(ඞ3):
            ඞ3=True
            try:
                def  go(this):
                    if (isinstance(print, (int))):
                              return
                              return [console.log.__class__]
                    return print
            except console.ඞError:
                print("ඞ")
    [[({ඞඞc:=input().go()})]]
    if ඞCඞඞ==0:
        ඞඞඞඞඞඞ+=ඞඞc * 0x02
    else:
                              if ඞCඞඞ==2:
                                           ඞඞn+=ඞඞc
    if ඞCඞඞ==4:
        ඞඞඞඞඞඞ = ඞඞc + ඞඞඞඞඞඞ
    if ඞCඞඞ==5:
                                                  
      ඞඞn+=ඞඞc[:-1] + ඞඞඞඞඞඞ[1] + ඞඞc[-1] + ඞඞඞඞඞඞ[1]
                                                        
      ඞඞඞඞඞඞ = ඞඞඞඞඞඞ[:1] + ඞඞඞඞඞඞ[2:] + ඞඞc[0]
    if ඞCඞඞ==6:
     ඞඞඞඞඞඞ = ඞඞc[0] + ඞඞඞඞඞඞ + ඞඞc[1] + ඞඞn
console.log(ඞඞඞඞඞඞ)
4 Likes

What is meant by Albert screaming?!

Which Language it use?

The language it uses is python

ahhhhhhhhmy eyesssss

1 Like

oh my gosh, it’s so beautfiul

1 Like

WHERE’S THE CRYING REACTION :sobs: MY EYESSSSSSSSSSS

3 Likes

1 Like

do you like how i put a class definition in the for loop and then defined the classmethod within a while loop :laughing:

1 Like

do you like how i put a class definition in the for loop and then defined the classmethod within a while loop :laughing:

@SharkCoding Yes, it’s perfect

1 Like

This was one of my favorite things I did :D

Have any of you ever even used the walrus operator?

I had not heard of the walrus operator but that could be very useful. I may be able to use it to make programs even fewer bytes. It saves lines for sure.

# Normal Python
myVar = "Hello world!"
print(myVar)
myVar += " I code in Python."
print(myVar)
# Walrus
print((myVar := "Hello world!"))
myVar += " I code in Python"
print(myVar)
4 Likes

@SharkCoding Yes, actually, it’s very much an underused operator that not a lot of people know about. It was added after the 3.8 update.
It called “walrus” because the colon (:) are the eyes and the equal sign (=) is the tusks.
Here is how you can use it in a program:

a = [1, 2, 3, 4]
if (n := len(a)) > 3:
    print(f"List is too long ({n} elements, expected <= 3)")
(Taken from here.)
1 Like

Oh you found a much better use for it than me. I will use this in like every program now.

3 Likes

Ok, your guys asked for it and it was madness to do this.
This is equivalent to the python print(“Hello World”) in the language called ///

Enjoy

//\\///\///////\///\\/\\\/\/\\/\
/\\\//\/\///\/\////\/\\/\/\/\/
\/\/\\\/\\//////\\///\///\///\/\
/\/\\\//\//\\\//\/\\\/\\/\\/\
\/\\/\/\\/\////\//\//\\/\/\\\///\
\\\///\\//\\/\\\/\\\\\/\\/\

I do enjoy this. It is mesmerizing artwork. I like this abstract art.

1 Like

Walrus makes code so much more efficient and slightly less readable:

while (thing := input((name := "Who are you?\n"))).lower().title() not in ["Steve", "Phil", "Shrek"]:
  thing = input(name)
# Rather than
name = "Who are you\n"
thing = input(name)
while thing.lower().title() not in ["Steve", "Phil", "Shrek"]:
  thing = input(name)
# Now for the maddening part
while (t:=input((n:="Who are you?\n"))).lower().title() not in ["Steve", "Phil", "Shrek"]: t=input(n)
4 Likes

Totally

import random;print([i:=random.choice([x for x in range(1, 101)]) for _ in range(10)], i)

3 Likes

I’ve seen 2k+ lines of code condensed all into a couple hundred lines and it was chaotic. :skull:

1 Like

Unfortunately when people are given the power of walrus … they start ti think shifter is better. PERL people loved to out all in one line and the goal was small and impossible to read (old times were weird).