This is seriously going to make me quit using and recommending this site

Commits to git work at best 1/20 times. I usually have to log out, clear all caches, then log back in, push my commits and say a prayer to every God I have heard of to maybe possibly get a successful commit. It should take a few minutes but it never does. This is insanely frustrating.

Hi @weblet , welcome to the forums!
What error message does it show?
Have you tried disconnecting and reconnecting Github at

Sometimes it is

Git Error


Failed to authenticate with the remote. Please ensure that Replit has access to this repository on GitHub.

Update GitHub Repository Access


but not always. I disconnect and reconnect to my git account frequently because of this. I think I am just getting throttled. I didn’t know I would be throttled in this way.

On Github, have you tried connecting and disconnecting access to Replit?

I just did that and it seems to have helped. Hard to know because sometimes the issue will go away for a while. Fingers crossed.

Happens to me all the time. I am switching to VS code. You can commit changes with a likely chance of them actually working.


I am very sorry to hear of your issues. This is a known issue that is being addressed by our engineering team. My suggestion would have also been to disconnect and reconnect, as that should solve the underlying issue. If you have any additional problems, please let us know and we’ll be happy to help. Thanks!