There was an error connecting to the server

Hi, users on Replit,

I am working on a Python project which needs to load the “turtle” library and facing the same issue as this thread, this thread, and this.

I’ve tried all the methods mentioned, including input “kill 1” in shell, clearing caches, opening the project in incognito mode, and loading Nix environment. However, none of these work.

Does anyone know how to fix it? Any insight would be appreciated.

Hi @CETutor , can you try forking this repl? I have helped people to solve this problem by forking the repl with the issue.

@NateDhaliwal Yes, I did that but the error message still exists. Please check this:

This is a bug that has been around lately.
@ShaneAtReplit , could you take a look? (Sorry to ping you)


This problem only exists in Team spaces, including Educaion and Friend tabs. No connection errors happen if I create a turtle project in My Repls.

1 Like

Is this still happening? This issue appears to be the same as: VNC Output Window not Connecting, which we have sent out a few fixes for.

Yes this is still happening
forking and kill 0 do not work
I get the same error when working outside teams
we rely on replit to teach students and we have not been able to use turtle or pygame for a week (these both use the output window)

1 Like

I am a teacher and use firewalled replit with all of my pupils. We have been experiencing the same problem this week.

Already tried forking repls, clearing cache and kill 1 in shell with no luck.

1 Like

The issue has not been fixed for the firewalled version of replit.

@rjolliff @sgcooper and @MrCDonaldson,

Can you please send me the link fo a Repl that isn’t working so we can take a look? Also, can you all please let me know if these work:

  1. Go to
  2. Go to

And let me know if either of those are blocked?

Many thanks for your response.

I’ve tried both the links and they work, however, I am still experiencing the same problem with my repls. When on our school network this happens with both the Firewalled and normal versions of replit. I’ve also tested it using 4G and get the same problems, strangely though only when using Firewalled replit.

Any further help on this would be greatly appreciated.

That’s strange. Would you mind sending a screenshot of the issue you’re seeing for Firewalled and normal Replit on your school network?

Of course - forgive these being mashed into one image, but the posting restrictions didn’t allow me to put them on separately.

Top left is normal Replit, bottom left firewalled and I included what it gives me on my phone via 4G too.

1 Like

This is the same as us @ShaneAtReplit. We are still having the same issues but we can open and connect to those links.

@sgcooper and @MrCDonaldson,

Do you know what your Internet Service Provider you have?

1 Like

I am not sure what the school uses. It does the same on Virgin while working from home.

This issue is occurring in both Firewalled Replit and non firewalled. We are also working in the Teams for Education part of Replit.

The two links to check if repl is allowed both work.

@ShaneAtReplit - We’re in England and use South West Grid For Leaning. My 4G is through Tesco mobile, who I believe use O2’s network.

@ShaneAtReplit These work for but is there one for firewalled replit version? We think we need to allow something on our end for the features to run via firewalled replit

The firewalled URLs are located in this doc, but I’ll list them here too:

  • *
  • *
  • *