The program does not work. When i start press on button Run it does not run

Question:

Repl link/Link to where the bug appears:
task_manager.py - PP - Replit
Screenshots, links, or other helpful context:

code snippet

It seems you have edited your .replit config file,

You may have done this unintentionally, but to get it to run the file you want you should change it to this

entrypoint = "task_manager.py"
run = "python task_manager.py"
modules = ["python-3.10:v18-20230807-322e88b"]

hidden = [".pythonlibs"]

[nix]
channel = "stable-23_05"


By default it should be

entrypoint = "main.py"
run = "python main.py"
modules = ["python-3.10:v18-20230807-322e88b"]

hidden = [".pythonlibs"]

[nix]
channel = "stable-23_05"

Simply replace main.py wherever it appears with the actual file you want to run, in this case task_manager.py

1 Like

If there’s already entrypoint, remove run.

1 Like

I tried this and it works, thank you, this was my first time using the CMUGraphics template.

I asked AI “is there any reason why having both run and entrypoint is preferred to just having entrypoint?”, but I don’t know if its response is entirely true or accurate :
I don’t fully understand what it’s differentiating.

Taken from a fresh .replit file:

entrypoint = "main.py"
modules = ["python-3.10:v18-20230807-322e88b"]

hidden = [".pythonlibs"]

It was originally run, but ut was updated to entrypoint. run can still be used but is entrypoint by default.

1 Like

Don’t bother asking the AI for advice on .replit config, it’ll probably just hallucinate.