The “language” config doesn’t do anything

why doesn’t the language option do anything when importing from GitHub?
literally they keeps auto-detecting as TypeScript not Nix.

or is there any way to configure the default template as Blank Repl when importing?

here’s my .replit:

language = "nix"

hidden = [".config", "pnpm-lock.yaml"]
# onBoot = "pnpm install"
run = "pnpm run start"

	requiredFiles = [".replit", "replit.nix", ".config", "package.json", "pnpm-lock.yarn"]

	channel = "stable-23_05"

	language = "nodejs-pnpm"

		packageSearch = true
		guessImports = true
		enabledForHosting = false


{ pkgs }: {
	deps = [

The language is either nix or html, those are the only options.

Almost every Repl you create will be a Nix Repl.


ah i see it make sense.
when importing, is there any way to configure the default workspace template to Blank Repl or smh, not TypeScript?
the TypeScript workspace template keeps adding a compile option to my .replit and errors because of it. even it’s not needed.
i have to import it several times for some reason and changing it to Blank Repl everytime is kinda annoying.

Before you click Import there should be a Language dropdown. If it defaults to TypeScript, change it to Blank Repl and it should work. Here’s a screenshot:


Change the dropdown above to Blank Repl, which should be the first option.

1 Like

^ i know. i mean, is there any way to configure that to default select Blank Repl when importing?

also the auto language detection is kinda absurd sometimes because it’s based on the project’s language usage. so the .replit config should be able to specify which language/library/framework Repl template to use.

I don’t think so.

For me, it’s usually helpful.

There is no .replit config in your GitHub repository, so it can’t specify until you import and select the language. Also it’s not that hard to just change the dropdown to Blank Repl.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.