The discord-py-interactions package doesnt work properly

Problem description:
Unable to install discord-py-interactions package

Expected behavior:
Install

Actual behavior:

Replit: Updating package configuration

--> poetry add 'discord-py-interactions 5.10.0'

Updating dependencies
Resolving dependencies...

  AttributeError

  'HTTPResponse' object has no attribute 'strict'

  at venv/lib/python3.8/site-packages/cachecontrol/serialize.py:54 in dumps
       50│                 ),
       51│                 u"status": response.status,
       52│                 u"version": response.version,
       53│                 u"reason": text_type(response.reason),
    →  54│                 u"strict": response.strict,
       55│                 u"decode_content": response.decode_content,
       56│             }
       57│         }
       58│ 
exit status 1

Replit: Package operation failed.

Steps to reproduce:
Installing discord-py-interactions

Bug appears at this link:

Browser/OS/Device:
Firefox/Windows/PC

To install this module, use this command:

poetry add discord-py-interactions

or this:

pip install discord-py-interactions
2 Likes

Hello @capreesunnn!

Since this is an error with urllib3, try this:

hey i tried this got a new error.

  SolverProblemError

  The current project's Python requirement (3.8.12) is not compatible with some of the required packages Python requirement:
    - discord-py-interactions requires Python >=3.10, so it will not be satisfied for Python 3.8.12
  
  Because no versions of discord-py-interactions match >5.10.0,<6.0.0
   and discord-py-interactions (5.10.0) requires Python >=3.10, discord-py-interactions is forbidden.
  So, because python-template depends on discord-py-interactions (^5.10.0), version solving failed.

  at venv/lib/python3.8/site-packages/poetry/puzzle/solver.py:241 in _solve
      237│             packages = result.packages
      238│         except OverrideNeeded as e:
      239│             return self.solve_in_compatibility_mode(e.overrides, use_latest=use_latest)
      240│         except SolveFailure as e:
    → 241│             raise SolverProblemError(e)
      242│ 
      243│         results = dict(
      244│             depth_first_search(
      245│                 PackageNode(self._package, packages), aggregate_package_nodes

  • Check your dependencies Python requirement: The Python requirement can be specified via the `python` or `markers` properties

is there anyone here that can help me with changing my python requirement i tried doing it but it failed?

the easiest thing to do is probably to just move everything to a new repl because the newer templates run python 3.10
you can download the entire repl as zip and then upload folders and files to the new repl, or just copy and paste all the code in

yeh i will do that its a 2 year old repl so it makes sense LOL

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.