Text in Console not Displaying

Bug description:
When I type in the console, characters are not visible until several characters are entered. The input statement retrieves the text correctly, but it is not visible in the console window.

Expected vs Current Behavior:
I expect to see characters that are typed in, but I am not seeing the text that I enter on the keyboard until a sixth character is entered.

Steps to reproduce:
I create a repl in Python and use the input function. x = input("Enter text: "). When I run and type in characters, five characters are invisible and then the sixth character causes the preceding characters to display in the console. The issue is the same when using the shell.

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

I think this is due to lag and your device, not Replit.

It happened to me before.

I think its this

Try clearing your broweser chache or try a different browser and see if that does anything.

I had tried clearing my browser cache and that did not help. I am now on a different computer and it is working correctly. I am not sure why the one computer is having issues when these are the same model computers on the same school network. I will try a different browser next.

Is there any extensions you’re using on that computer?

I dont think its lag, if it were, surely it would just take a bit of time to load rather than requiring that 6th character always. Classic unreliable replit


Cannot reproduce this bug:

Please try it on a different device and post with the results, it will give a bit more information. I personally think this is related to your device, but it’s just a guess.

Fixed by turning on hardware acceleration in chrome settings

1 Like

As of now, from my observations, the problem is still occurring with Edge 115.0.1901.188. It’s not with Firefox 116.0.1 and it’s not happening with my Android phone running Brave browser. I figured the problem as localized to your interactive syntax highlighting code that’s used in the Console and Shell windows. It’s something to look at, unless you just don’t want to. Even though the user supplied text is all one color as far as I can tell, it is behaving as if there is a syntax highlighting functionality in place and only being used to color parts of the prompt.

I am a teacher and for the past few months most of my students are getting this issue. Very frustrating.
A few said it also happens on their own personal devices so must be more common or linked to the Education Team?

Not sure how to even go about trying to fix this. I usually have to input a few blank spaces for the outputs to show properly.

Hey @MrButcherIT!

For the students affected by this issue, does it happen to any Repl they view, or only certain ones? Do they have any browser extensions installed, and can they try disabling all of them?

I am currently having the same problem in the shell, and have been for a while. I also used to have it in the console before the update to the console. I start typing, and the text only appears after i type quite a few characters. I am working on brave browser on windows. I have tried clearing cache and it did not fix it.

Hey @NevioCarta1!

Have you tried using a different browser to see if that fixes the issue? And does this happen for all of your Repls or just certain ones?

It appears to work fine on chrome. butnon brave, it happens on all my repls

Do you have any extensions in Brave? If so, can you try disabling them? Also, can you try toggling hardware acceleration in Brave to see if that changes things?