T3-app running into SSL issues from Prisma lib

Following this tutorial

Repl: https://replit.com/@bardia/twitmoji

Running into this error when running rpm run dev

error - unhandledRejection: Error: libssl.so.1.1: cannot open shared object file: No such file or directory
    at load (/home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:73:679)
    at /home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:73:1146
    at runInChildSpan (/home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:70:25817)
    at Br.loadLibrary (/home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:73:1064)
    at async zt.loadEngine (/home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:101:557)
    at async zt.instantiateLibrary (/home/runner/twitmoji/node_modules/@prisma/client/runtime/library.js:100:1471) {
  digest: undefined

I added the openssl nix package to my replit.nix file but it doesn’t seem to be picking it up (even after running kill 1)

Anyone have any ideas on how to fix?

Is the openssl lib in $LD_LIBRARY_PATH?

1 Like

I ran this in the shell:

export LD_LIBRARY_PATH="/nix/store/fq47cv26nb87hwz2678r6i8ym5b57lwf-openssl-3.0.7-bin/lib:${LD_LIBRARY_PATH}"

and in the same shell tab I still get the same error


Try adding pkgs.openssl_1_1 to replit.nix.

1 Like