Students can't download replit assignment as zip

Students in my edu Team downloading projects (HTML/CSS/JS) as .zip get a 404 error. I verified this with my fake student account. I am able to download student projects as .zip from my teacher account, but students cannot download their own.

1 Like

Hi @dbwetzel , welcome to the forums!
Your students can go to the following link:
Do note that you’ll need to change team-name and repl-name with the team name and repl name respectively.

1 Like

Not working. Still getting 404 error

1 Like

Hey @dbwetzel!

Can you please send me a link to one of the Repls that your students are having trouble downloading?

This is my “student” account that I use to monitor the student experience in my class (intro programming in P5.js). Everything works from my teacher account. Students that completed the first lab on Wednesday August 30 had no trouble downloading. Students that tried it on Thursday August 31 got the 404 error. That has been the case for the entire Team since that date.

David B. Wetzel, DMA
Lecturer in Interdisciplinary Computing
Department of Computer Science
Affiliate Faculty in Music
Loyola University Chicago

We no longer support the *.zip URL format to download Repls as a ZIP. You can still download them via the three dots menu in the file tree, however.

Hi Shane, this still does not work for my students. They click the download as zip and still get the 404 error mentioned above. The issue seems to be it does still go to the old format as the URL nad cause the 404 error and does not zeem to be away for them to download it otherwise as thats what the three dots “download as zip” does

This is the method I instructed my students to use, and where we encountered the error. I don’t have this problem with my own personal repls, or from the “teacher” side in the Team for Education. It only seems to happen to my students in their Team repl assignments. Again, only on and after Thursday August 31.

Thank you both for the information. I was able to reproduce the issue and have flagged this to the team. I will follow up here once I have an update.

Hey all!

We have recently released a fix for this issue, so your students should no longer see a 404 page. If this is not the case, please let me know, and I will take another look!


I am experiencing an equal error. Clicking the download as zip link in a student repl results in an 404 error.

It appears that our fix didn’t cover all cases so some users are still having issues. We are taking another look!

Also, as a workaround, you should be able to use to download Repls as a ZIP!

That repl doesn’t appear to be running when I try to vist it. (And doesn’t link to the Repl either, was it renamed?)

That’s my bad, I didn’t realize we took our zip tool down. I’ll see if we can get that back up and will also follow up with the team to make sure we’re looking into the underlying ZIP issue with student’s Repls!

1 Like

We can have a fix out for the ZIP issue by today or tomorrow. I will send out another update once the fix is out!

We have sent out a fix for the issue that accounts for the rest of the cases we missed previously. Please let me know if your students are still having issues when trying to download their projects as a ZIP file!

Thanx, it works like a charm again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.