Student Google Classroom invites not working

Problem description:
Students were emailed a link to join my class/team. I did this through the “Invite via Google Classroom” button.
Students then clicked on the main button in the email to have them join. It didn’t work. So then they tried some of the other links that were in the email. These made an account for them but it didn’t add them to the team. It also gave their account names a bunch of numbers, instead of their name that should be retrieved from Google Classroom.
So now I need to have all the students use the CLI and hope that they type their name correctly. Then I have to have them join using the “Generate a team invite link”.
It worked yesterday but things went bad today.

Expected behavior:
Students click on the link in their email, it adds them to my team, and their names are correct.

Actual behavior:
Stated above.

Steps to reproduce:
Teacher makes a team, clicks on the “Invite via Google Classroom”, chooses the classroom. Then students click on the main button in their email. That doesn’t work so they click on the link below that button.

Bug appears at this link:
Not at a particular link.

Browser: Chrome
OS: Windows 10
Device (Android, iOS, NA leave blank): PC
Desktop app version (Avatar menu->“Version”) or NA: NA
Plan (Free, Hacker, Pro Plan): Education

Hi @DavidHust1, thanks for your report. Does your class/team contain students under the age of 13? It sounds like they were sent privacy invite links instead of Google Classroom invites.

1 Like

All of my students are older than 13.

Can you say more about this? What did the students see after clicking the link in the email?

Thanks for the reply. I’m no longer able to see what happened since we pushed past that issue. All I know is that students pressed the main button in the email and it didn’t add them to my class. It also gave them a username that was only numbers. I had them go to the CLI and change their name. Then I had them use the invite code instead.