Stuck on Booting Repl

Problem description

Replacing venv with old venv (yes this is problematic behavior) freezes the repl. (https://replit.com/@darkcalm/bcd)

Expected behavior

Show what’s stuck or offer to discard this change.

Actual behavior

Freezes the repl. Same after reload.

Steps to reproduce

  1. Start Python Repl
  2. pip install some package
  3. version to remote location (github)
  4. replace venv with remote venv

Browser

Firefox

OS

Mac OS

Device if mobile

N/A

Plan

Core

Hi @darkcalm , welcome to the forums!
Your repl, using venv, is an outdated configuration. To update it, could you try entering this code in the Shell:

curl -s https://firepup650.replit.app/raw/minifier|bash -s

Made by a Jr. Mod on this forum, @Firepup650, and is highly trusted.
Also, try to use poetry instead of pip as pip can be buggy. The Replit staff are working on a fix, IIRC.

5 Likes

Hi, this looks like a good solution, although the Shell is not interactive while the repl is stuck on booting. I think it might require intervention from the team to at least take the repl out of stuckness, as they did with Stuck on "Booting Repl".

Thanks for looking at the issue @NateDhaliwal!

@darkcalm @DrewAndersen If it still doesn’t load, try pressing CTRL+SHIFT+R to refresh the page and cache?

I have same issue. Server issue have to wait forever.

waited for a few hours before reboot is complete, retired venv, updated, and continued with poetry.

i have same issue not booting up

Hey @lifeofGash welcome to the forums!

Have you tried refreshing your Browser Cache (CTRL+SHIFT+R or CMD+SHIFT+R)?

1 Like

yes, i retest it rn and doesn’t work again

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.