Steam a2s requests are getting timed out

Bug description:
Hey, I was trying to communicate a steam game server using steam library in python using a2s. Cant seem to get any information from the game server when I run it on replit. Getting timed out even with 2s timeout limit.
I can confirm that I am getting the server info if I run the same code in my local machine

Expected vs Current Behavior:
Expected: Print steam game server info like

{'_ping': 81.00647926330566, '_type': 'source', 'protocol': 17, 'name': 'The Shadow Realm | No Wipe Server', 'map': 'VRisingWorld', 'folder': 'V Rising', 'game': 'f082ba51-202f-4b79-b123-497e5fbed216', 'app_id': 1604030, 'players': 10, 'max_players': 50, 'bots': 0, 'server_type': 'd', 'environment': 'w', 'visibility': 0, 'vac': 1, 'version': '', 'edf': 177, 'port': 31100, 'steam_id': 90176764541709340, 'keywords': 'pve,cs4,ded,sal_hi', 'game_id': 1604030}

Current: a2s requests are getting timed out. Cant seem to communicate with the game server.

Steps to reproduce:
Run my repl

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Replit Profile:

Hey @manjunathbsk3!

Thank you for reporting this issue. I was able to reproduce this and have flagged this to the engineering team. I will follow up in the thread once I know more.

Any updates regarding this?

No updates as of yet. We will follow up with the right people internally this week and follow up with you.