SSL for custom domains are not working - 72 hrs passed since linking

I’ve tried 3 repls with 2 different DNS providers: namecheap and godaddy.

If I access the custom domain on HTTP, it says: ’ Run this Repl to see the results here.’ although repl is running.

With HTTPS, it says:

This site can’t provide a secure connection

domain sent an invalid response.


I’ve looked up some old threads where most people suggested waiting so I did, and the results are same after 72 hrs.

Another info I’d include is: TXT records exists for namecheap but not for godaddy. But it worked for neither. Let me know if there’s a way to fix it.

Yes, I am facing the same issue. Waited for domain propagation but now getting the same ERR_SSL_PROTOCOL_ERROR on my custom domain,

Welcome to the community both of you! Replit is redoing a lot of stuff due to Replit Deployments. These will be the new way of hosting your Repl ( or something), but your sites will still work. It’s possible that somebody broke something working on this transition and that it will all be fixed soon.


eventually it works itself out

1 Like