SSL Error After Deploying Webapp

Problem description:
I am receiving an SSL error when I navigate to the URL assigned by my Autoscale deployment. Since this repl is a microservice for my dashboard application, the root path redirects to the login (at top level domain) if the user is not logged in. The top level domain is on another deployment and works fine (see https://finned.tech). The issue could possibly be related to this.

Expected behavior:
No SSL error, site should load as expected.

Actual behavior:
I get an SSL error and a Cloudflare page saying “Invalid SSL Certificate”

Steps to reproduce:
Appears to be unreproducible, happens only on this one specific repl. Repl worked fine before deployments.

Bug appears at this link:
Assigned domain - https://finned-player-data-flancast90.replit.app/

Browser: MS Edge
OS: Win11
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Replit Core): Hacker

It works for me, can you share a screenshot of what it looks like when you try to load your deployment?

Just verified it doesn’t work on other devices. I’m away from my computer right now, but the error is the same when I navigate to the page on my phone.

@lincoln-replit , you’re most likely being redirected to the sign in page, as you would not be logged in to the app. The microservice containing the dashboard app is where I’m getting this issue.

Can you show what the DNS records in your cloudflare dashboard look like?

Here you go:

@lincoln-replit, I was able to fix the SSL error by removing a few redundant DNS entries (CNAME from before deployments). However, now when I navigate to the domain (I have re-added the same domain and waited a few days to ensure DNS has all propagated), I get an error “Can’t reach this page… check if there is a typo.”

In my deployment settings, it shows the custom domain as added and verified. Additionally, the initial domain (https://finned-player-data-flancast90.replit.app) gives the same error.

Further info - the automatically assigned link now works when there’s no redirect/auth on the “/” root path. However, custom domains still don’t work for some reason (I tried with my usual https://fpd.finned.tech, and made sure there wasn’t DNS silliness going on by making an entirely new subdomain at https://test.finned.tech to test). Same issue on both, can’t reach the page.

To anyone that runs into this problem, I’ve been able to solve it and will detail the solution below:
In addition to the A and TXT records replit requires to be added, for any subdomain, you must also add a CNAME record pointing to the automatically assigned domain. Otherwise the custom domain will not resolve.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.