SSH authentiaction fails - public key permission denied

Question:
I have setup SSH into my repl a couple days ago. Both using vscode as well as a normal ssh client worked just fine. Today I can not authenticate anymore at all. I tried readding and following the instructions again no change. https://docs.replit.com/power-ups/ssh

Is there anything I am overlooking or changed the last few days ?

Screenshots, links, or other helpful context:
user@replit… Error message: Permission denied (publickey).

Hi @pfeiffersimon , welcome to the forums!
Try unlinking the key and make a new one, and use the new one.
Did you change the key value, or delete it accidentally?

Hi Nate thanks for the suggestion. I had created multiple extra keys to test according to the describe procedure so that should have solved it too, right ?

Interestingly this morning without changing anything on my side the key was accepted again.

So it is resolved for now at least :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.