Source files are loosing changes and getting out of sync

Bug description:

It has been crazy 2 days. I worked on my source code saving it (CRTL+S) all the time. It shows formatting source code etc. (I’m quire sure even reloading web-page sometimes too… it’s been two days). I had problems because I could not fix one issue. Did a huge refactoring could not understand why application simply stops in one place. Then I closed my source file and reopened it :scream: - all changes are two days old, nothing refactored, no possibility to get it back!

Today I was careful to close my source file and reopen time by time. Noticed that the same issue happened TWICE during the day! I guess it’s because I went for lunch or something and my PC went to sleep (however, I don’t believe it as I KNEW about the bug and tried to reopen the source file).

I find this issue so serious, so annoying that anyone who uses Replit may spend hours investigating issues that are not there and loosing hours of work, because not closing and reopening source files every time you come to the computer.

I didn’t see this issue as often in October, and not sure if it’s related to the September update.

Expected vs Current Behavior:

Every time you save a file (CRTL+S) when it shows “File formatted…” it should say “FILE OUT OF SYNC, DO YOU WANT TO OVERWRITE” or similar. Best if it even happens without saving but checked regularly in background.

Expected to show “real” source code as on Replit disk, warn if file is actually NOT saved.

Steps to reproduce:

Write some code, go make some coffee, write some more code - then close and reopen the source file. Note that it’s my guess that it’s related to the computer going in to sleep more - honestly I feel it’s happening even while I code or just switch to other tabs (which is probably equal to leaving PC).

Screenshot(s)/Screen Recording:

not applicable

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile: private

Hello, try to recreate repl if you can

That’s not actually “Save” on Replit, it’s actually “Format Code”.

1 Like