Some users are having trouble connecting to MongoDB

Any update on this issue?

2 Likes

No, it’s Replit’s issue

1 Like

ok. like the mongodb api driver?

2 Likes

A post was merged into an existing topic: Current issue | Incidents

Any update @ShaneAtReplit. This isn’t fixed and is really annoying as I’m using both ReplAuth and Mongo, so I can’t just switch to another hosting platform.

1 Like
1 Like

I’am having this issue with a private replit. Here’s the error message I got after trying to connect to the mongo db_Atlas.

Here’s the dig command results:

; <<>> DiG 9.16.16 <<>> @1.1.1.3 marketinteligence-lb.bp3bj.mongodb.net
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 1658
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;marketinteligence-lb.bp3bj.mongodb.net. IN A

;; Query time: 11 msec
;; SERVER: 1.1.1.3#53(1.1.1.3)
;; WHEN: Sun Mar 19 21:02:35 UTC 2023
;; MSG SIZE rcvd: 67

If you need more information, please tell me.

Thanks.

Thank you for sending in the new reports! We have been able to reproduce the issue and are working internally to investigate and identify the issue. I will send another update once we have made progress with our investigation.

1 Like

Thanks in advance!

This is an intermitent issue my repl is working today.

But it happened to me 3 our 4 times for a couple of days.

Will you be posting the solution once this has been fixed?

/home/runner/usdtminer/node_modules/mongodb/lib/sdam/topology.js:285
                const timeoutError = new error_1.MongoServerSelectionError(`Server selection timed out after ${serverSelectionTimeoutMS} ms`, this.description);
                                     ^

MongoServerSelectionError: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net
    at Timeout._onTimeout (/home/runner/usdtminer/node_modules/mongodb/lib/sdam/topology.js:285:38)
    at listOnTimeout (node:internal/timers:559:17) {
  reason: TopologyDescription {
    type: 'ReplicaSetNoPrimary',
    servers: Map(3) {
      'ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net:27017' => ServerDescription {
        address: 'ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net:27017',
        type: 'Unknown',
        hosts: [],
        passives: [],
        arbiters: [],
        tags: {},
        minWireVersion: 0,
        maxWireVersion: 0,
        roundTripTime: -1,
        lastUpdateTime: 10947105,
        lastWriteDate: 0,
        error: MongoNetworkError: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net
            at connectionFailureError (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:387:20)
            at TLSSocket.<anonymous> (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:310:22)
            at Object.onceWrapper (node:events:628:26)
            at TLSSocket.emit (node:events:513:28)
            at TLSSocket.emit (node:domain:489:12)
            at emitErrorNT (node:internal/streams/destroy:157:8)
            at emitErrorCloseNT (node:internal/streams/destroy:122:3) {
          cause: [Error: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net] {
            errno: -3008,
            code: 'ENOTFOUND',
            syscall: 'getaddrinfo',
            hostname: 'ac-3yjb9xp-shard-00-00.b1uczns.mongodb.net'
          },
          [Symbol(errorLabels)]: Set(1) { 'ResetPool' }
        },
        topologyVersion: null,
        setName: null,
        setVersion: null,
        electionId: null,
        logicalSessionTimeoutMinutes: null,
        primary: null,
        me: null,
        '$clusterTime': null
      },
      'ac-3yjb9xp-shard-00-01.b1uczns.mongodb.net:27017' => ServerDescription {
        address: 'ac-3yjb9xp-shard-00-01.b1uczns.mongodb.net:27017',
        type: 'Unknown',
        hosts: [],
        passives: [],
        arbiters: [],
        tags: {},
        minWireVersion: 0,
        maxWireVersion: 0,
        roundTripTime: -1,
        lastUpdateTime: 10947104,
        lastWriteDate: 0,
        error: MongoNetworkError: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-01.b1uczns.mongodb.net
            at connectionFailureError (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:387:20)
            at TLSSocket.<anonymous> (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:310:22)
            at Object.onceWrapper (node:events:628:26)
            at TLSSocket.emit (node:events:513:28)
            at TLSSocket.emit (node:domain:489:12)
            at emitErrorNT (node:internal/streams/destroy:157:8)
            at emitErrorCloseNT (node:internal/streams/destroy:122:3) {
          cause: [Error: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-01.b1uczns.mongodb.net] {
            errno: -3008,
            code: 'ENOTFOUND',
            syscall: 'getaddrinfo',
            hostname: 'ac-3yjb9xp-shard-00-01.b1uczns.mongodb.net'
          },
          [Symbol(errorLabels)]: Set(1) { 'ResetPool' }
        },
        topologyVersion: null,
        setName: null,
        setVersion: null,
        electionId: null,
        logicalSessionTimeoutMinutes: null,
        primary: null,
        me: null,
        '$clusterTime': null
      },
      'ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net:27017' => ServerDescription {
        address: 'ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net:27017',
        type: 'Unknown',
        hosts: [],
        passives: [],
        arbiters: [],
        tags: {},
        minWireVersion: 0,
        maxWireVersion: 0,
        roundTripTime: -1,
        lastUpdateTime: 10947188,
        lastWriteDate: 0,
        error: MongoNetworkError: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net
            at connectionFailureError (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:387:20)
            at TLSSocket.<anonymous> (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:310:22)
            at Object.onceWrapper (node:events:628:26)
            at TLSSocket.emit (node:events:513:28)
            at TLSSocket.emit (node:domain:489:12)
            at emitErrorNT (node:internal/streams/destroy:157:8)
            at emitErrorCloseNT (node:internal/streams/destroy:122:3) {
          cause: [Error: getaddrinfo ENOTFOUND ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net] {
            errno: -3008,
            code: 'ENOTFOUND',
            syscall: 'getaddrinfo',
            hostname: 'ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net'
          },
          [Symbol(errorLabels)]: Set(1) { 'ResetPool' }
        },
        topologyVersion: null,
        setName: null,
        setVersion: null,
        electionId: null,
        logicalSessionTimeoutMinutes: null,
        primary: null,
        me: null,
        '$clusterTime': null
      }

i had this problems 2 times
last time i change the mango account , its fixed auto at next day .
this time i havent change account . please keep updating so that we know how to do

Try checking the IP address for ac-3yjb9xp-shard-00-02.b1uczns.mongodb.net and using that IP address instead of a hostname to connect. (If the issue’s DNS, why not remove DNS? )

i read the mongo cluster documents, the cluster is not an host , it is a group of hosts,it has many Ip address(that may change dynamicallly )as specified by its seed list . so if i connect right today, maybe tommorrow it wont be working

will there be any update of how to fix it ?

/home/runner/usdtminer/node_modules/mongodb/lib/sdam/topology.js:285
                const timeoutError = new error_1.MongoServerSelectionError(`Server selection timed out after ${serverSelectionTimeoutMS} ms`, this.description);
                                     ^

MongoServerSelectionError: getaddrinfo ENOTFOUND cluster0.s5hnrg0.mongodb.net
    at Timeout._onTimeout (/home/runner/usdtminer/node_modules/mongodb/lib/sdam/topology.js:285:38)
    at listOnTimeout (node:internal/timers:559:17) {
  reason: TopologyDescription {
    type: 'Unknown',
    servers: Map(1) {
      'cluster0.s5hnrg0.mongodb.net:27017' => ServerDescription {
        address: 'cluster0.s5hnrg0.mongodb.net:27017',
        type: 'Unknown',
        hosts: [],
        passives: [],
        arbiters: [],
        tags: {},
        minWireVersion: 0,
        maxWireVersion: 0,
        roundTripTime: -1,
        lastUpdateTime: 34585168,
        lastWriteDate: 0,
        error: MongoNetworkError: getaddrinfo ENOTFOUND cluster0.s5hnrg0.mongodb.net
            at connectionFailureError (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:387:20)
            at Socket.<anonymous> (/home/runner/usdtminer/node_modules/mongodb/lib/cmap/connect.js:310:22)
            at Object.onceWrapper (node:events:628:26)
            at Socket.emit (node:events:513:28)
            at Socket.emit (node:domain:489:12)
            at emitErrorNT (node:internal/streams/destroy:157:8)
            at emitErrorCloseNT (node:internal/streams/destroy:122:3) {
          cause: [Error: getaddrinfo ENOTFOUND cluster0.s5hnrg0.mongodb.net] {
            errno: -3008,
            code: 'ENOTFOUND',
            syscall: 'getaddrinfo',
            hostname: 'cluster0.s5hnrg0.mongodb.net'
          },
          [Symbol(errorLabels)]: Set(1) { 'ResetPool' }
        },
        topologyVersion: null,
        setName: null,
        setVersion: null,
        electionId: null,
        logicalSessionTimeoutMinutes: null,
        primary: null,
        me: null,
        '$clusterTime': null
      }
    },
    stale: false,
    compatible: true,
    heartbeatFrequencyMS: 10000,
    localThresholdMS: 15,
    setName: null,
    maxElectionId: null,
    maxSetVersion: null,
    commonWireVersion: 0,
    logicalSessionTimeoutMinutes: null
  },
  code: undefined,
  [Symbol(errorLabels)]: Set(0) {}
}
repl process died unexpectedly: exit status 1

this is the new error , i changed a new mongo account

We have been able to reproduce this as it appears to be spiking again. We have notified an upstream service about the issue and as of now, we are waiting for them to respond so we can move forward with the investigation.

3 Likes

I can confirm that it was working yesterday on my Repl but not today.

2 Likes

This issue seems to appear for me when I work on my Repl at a specific time. Realized this was a platform issue when I tried connecting the Repl to another cluster.

1 Like

Yeah, I tried that too before I hit the community page here looking to see if anyone else reported it. Do you see this happening consistently at specific times?

also find out same error here using same code in diff proj seems like only some of them occur the issue