(Solved) Deceptive Site Ahead (Red Warning Page)

Problem: Deceptive Site Ahead (Red Warning Page).

When I googled it, I found a kinsta article which said incorrect ssl config may also lead to this warning.
But it seems ssl it auto managed, so I can’t do anything about it.

Most google results from replit.com are 2yrs old.
replit deceptive site ahead - Google Search

Already reported to google that it’s a safe site as suggested by replit articles.

The website I have developed uses Google Auth which uses their account data to display results and hence I want the code to be public, so they can look at the code, believe it’s authenticity.

I know I can make the git repo public + link it to a custom domain, but I feel that it’s better to run the code where they can view it.

Kindly suggest.

This is a warning I’ve had pop up before on one or two specific Repls, but eventually it went away and it was only for those particular Repls. You should be able to ignore the warning and find a button somewhere to continue to the site despite the risk (which is normally not advisable, but in this case if you made a Repl you know exactly what you’re accessing). Shane (a member of the Replit team) might be able to fix this :slight_smile:

cc: @ShaneAtReplit



This has happened 2 times before and IIRC it was fixed both times but now you are getting this also…


When not-ethan starts SHOUTING then you know it’s serious


thanks for the quick reply guys.

if i link a custom domain, is there a way to show users that the site is genuinely running on a public repl? or if i visit the public repl page and click ‘open website’, the repl website will open via custom domain url?

Probably a feature idea:
Option to add a ‘View on Replit’
So they can be sure that the instance of code that is running is publicly viewable.

Hey guys, I managed to fix this.
So the google login button url was ‘name.user.repl.co/google’ - since it was redirecting user to google auth page.
But when I changed it to ‘name.user.repl.co/login’ - it stopped throwing that warning.

After doing so, the links on the page still didn’t load using https protocol.
I’m on Laravel, adding this below line at the end of web.php file fixed it:


Hope this is helpful to others. Thanks everyone.

1 Like

ok. that was silly of me. the naming convention of the endpoint was not the issue.

infact, as mentioned in my initial post, I had submitted to google that this is a safe site.
It looks like it took some time on their end, but that is what fixed it.
As soon as I changed the project name which changed my url, the error started showing up again.

Incase this happens to someone, submit your web url to this link and wait for ~24hrs for the google team to flag it as safe: Report Incorrect Phishing Warning

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.