Shell doubling or tripling inpit, across all replit, all browsers?

Just as the title says, the shell is doubling or tripling every character we type. This is happening in different replit, different computers, even with different users. (it was reported first by my students).

Never seen this bug before. Any idea? I don’t see any outage right now.

1 Like

quick update, the ‘Console’ works ok, only the shell is buggy

Can you send us a screen recording showing the error?

1 Like

Sure thank you, keep in mind is not my computer as the issue was first reported by a student, working on his own replit at a totally different geographical location

I can reproduce this. We are investigating.

1 Like

Yeah I’m experiencing this too. Extremely frustrating as I cannot publish the latest changes to my package to NPM.

1 Like

Bug description:
So every time i typed in shell, the letter that i typed is doubled, and sometimes tripled. For example :
when i typed : test
on shell : tteesstt

I tried, re-login and cleared cached, but it doesn’t seem to work.

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

good to know its not just me, I was driving crazy, blaming the keyboard / network / students :stuck_out_tongue:

The problem with the shell has been resolved. Please refresh your Repl.


Problem description:*
when i type in shell it dublicates my words like i type: npm space
It does: npmnpm

OS: android 13 samsung galaxy a14 2022 phone
Device (Android, iOS, NA leave blank):android
Desktop app version (Avatar menu->“Version”) or NA:2.53.2
Plan (Free, Hacker, Pro Plan):free

Thank you very much guys!

Hey, Thanks for the quick resolved!

I have the exact same issue

Try a refresh, and if that doesn’t work, a hard-refresh (Ctrl+Shift+R). If that still doesn’t work, try signing out, then back in.

Problem description:

I take a break from coding for a bit, so my Repl shuts off.

Expected behavior.

I go into the shell and get a quad-instanced monstrosity.

If you watch the video, you can see that for every key press, it’s typed four times.

When I executed an invalid command, it did it four times as well.

Another user experienced similar behavior (link) (friends of Replit discord server)

Expected behavior:
When a Repl disconnects and reconnects, there should only be one instance of the shell.

Actual behavior:
The shell decides it’s lonely and calls some buddies over.

Steps to reproduce:
Creating a consistent repro is pretty tricky. It might be possible to remotely use the new API to restart a Repl via kill 1.

I’ve not tested this out yet.

Bug appears at this link:
This bug is confirmed to have reproduced itself in multiple Repls.

Repl Link (private):
Repl ID: 614cf7f9-2ede-4fb9-9adf-3ea8e70dbc36

Browser: Chrome (Repro’d in desktop app)
Device (Android, iOS, NA leave blank): Macbook Pro 14" Ventura
Desktop app version (Avatar menu->“Version”) or NA: 1.0.0
Plan (Free, Hacker, Pro Plan): Pro Plan


This was seemingly fixed about an hour ago. Try refreshing your repl and see if the bug still occurs.

The fix should be rolled out.


Y’all are shipping on steroids!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.