Selenium with Chromium doesn't work anymore? how to use Selenium without output display

I’m using Selenium to get web page information and everything worked fine but from yesterday it seems Chromium (or Firefox) doesn’t work anymore …
When I start the driver, it loads the .nix Chromium and then stops with an error.
It is the same with Firefox.

Here is a very simple repl that shows the issue… It worked fine yesterday and now it cannot start anymore

I have created a brand new Repl using pypeeter which also uses Chromium and it is the same … it says Chromium has closed …

What can I do ? is there a change in the configuration to make ?

1 Like

Uncomment the headless argument in so it doesn’t use the display

1 Like

yes that’s a good idea but I need the window to make it work with the site i want to scrape.
In fact the issue is coming from the lack of video display / output that affects many repls right now … Hopefully it should be fixed soon

1 Like

(The process started from chrome location /nix/store/z0b6n2bqlssqwd9va76mb8flcwwzywc9-chromium-98.0.4758.102/bin/chromium is no longer running, so ChromeDriver is assuming that Chrome has crashed.)

I have the similar problem. Is it the similar error that you’re having?

Keep an eye here for when it will be resolved

1 Like

would Firefox with virtual display work?

I doubt it, as all Output/Display* programs do not work right now.

* - Anything that requires a screen

It works. I was asking whether it’d work for the website they want to scrape

yeah it seems to work … I have tried to integrate it in my main program but there is still an error.
What did you change in the repl.nix ? you have just added the FIREFOX variable ?

I also added pkgs.xorg.xorgserver to the deps

1 Like

great, it works fine !
Even if I would love to see the Output window back for many projects, my main issue about Selenium is fine with your solution … Great job ! Thanks :slight_smile:

Is there a way like this with pupeeteer?

1 Like

Nvm, got it…


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.