Runnning Flet version solving failed

Question:
I try to run a Flet project that is working and it shows me errors in the version, I passed it requirements.txt and it tells me in the console:

Because no versions of freight match >0.10.1,<0.10.2 || >0.10.2,<0.10.3 || >0.10.3,<0.11.0
  and flet (0.10.2) depends on flet-runtime (0.10.2), flet (>0.10.1,<0.10.3 || >0.10.3,<0.11.0) requires flet-runtime (0.10.2) .
And because flet-runtime (0.10.2) depends on flet-core (0.10.2), flet (>0.10.1,<0.10.3 || >0.10.3,<0.11.0) requires flet-core (0.10 .2).
And because flet (0.10.3) depends on flet-runtime (0.10.3)
  and flet-runtime (0.10.3) depends on flet-core (0.10.3), flet (>0.10.1,<0.11.0) requires flet-core (0.10.2 || 0.10.3).
And because flet (0.10.1) depends on flet-runtime (0.10.1)
  and flet-runtime (0.10.1) depends on flet-core (0.10.1), flet (>=0.10.1,<0.11.0) requires flet-core (0.10.1 || 0.10.2 || 0.10. 3).
Because no versions of flet-pyodide match >0.17.0,<0.18.0
  and flet-pyodide (0.17.0) depends on flet-core (0.17.0), flet-pyodide (>=0.17.0,<0.18.0) requires flet-core (0.17.0).
Thus, flet-pyodide (>=0.17.0,<0.18.0) is incompatible with flet (>=0.10.1,<0.11.0).
So, because python-template depends on both flet (^0.10.1) and flet-pyodide (^0.17.0), version solving failed.
exit status 1

I have tried changing .replit:

[packager.features]
packageSearch = false
guessImports = true

But it doesn’t work, I also tried updating flet, but then it goes crazy and tells me that it can’t find the flet_js module.

Maybe it’s silly but I’m new to this and have no experience.

I would appreciate your help

Repl link:

code snippet

Open your .replit file and try inserting this, near the top:

disableGuessImports = true
disableInstallBeforeImport = true

Then, reload.
This will disable the packager automatically trying to guess and install packages (as it may be wrong). I’m assuming you don’t need flet-pyodide.

Check your pyproject.toml to ensure that there are no packages installed that you don’t need. If there are, do poetry remove package-name in the shell.

If you want to install packages, do poetry add package-name in shell, or use the Packages tool.

2 Likes

Thank’s it work with:

disableGuessImports = true
disableInstallBeforeImport = true

But could not uninstall poetry, but Work!!!
Thank’s!!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.