Running repl in the background without having to run it each time

Can someone please help me? the relit is not running in the background meaning my chat bot doesn’t work unless I run it each time. How do I keep replete running in the background to keep my chat bot active? Thank you.

Replit Profile:

Hey @seancrisell!

You can use a Reserved VM Deployment so your bot has 99.9% uptime and should stay on to do what you need it to do. I hope this helps!


Thank you for your reply. I am using a Reserved VM, I’m guessing I’m missing a step somewhere. I still have to run each time, what am I doing wrong?

@seancrisell its deployed, so you either just have to run once and it stays on, or is something else happening?

I still have to run it each time

The repl is still running – The bright green “Run” button at the top of the screen does not deploy it, and the deployment logs do not display in the output. Instead, you have to go to the Repl, press New Tab, type “deployments” and press logs.

1 Like

How do I keep it running in the background? as soon as I close my desktop the bot shuts down. its running and deployed. Im sorry, please excuse my ignorance.

Reserved VMs always stay on, even when you close your desktop. If it stops, check for bugs in your code in the Deployment Logs.

1 Like

If it is a Discord bot, try pinging it on Discord or any way to access your bot without it being run. Your bot should run, but make sure it has the Background worker option in the Reserved VM deployment.