Root domain connection failure

I have a few root domains that doe snot work (e.g. the mirror which is a www. (, is still ok somehow

so no idea if anyone else has the same issue.

The repls themselves are new, nodejs, and connection attempts were made via both A and cname to no avail.

UPDATE: i forgot to mention it does link, and that it just refuses to run

the domain and repl has been lined for a few days now.

Hey @WoonSeng1!

I am sorry to hear that you’re having issues with domain linking. I was able to reproduce the issue and have sent it to the team. I will follow up as soon as I have an update!

Hello @ShaneAtReplit it would seem that replit has a weird characteristic, I remember when root domain linking still worked, there was a period of time where i noticed cname records were faster than A not just in linking, but also general connections.

The propagation times for different DNS records depends on your provider and the health of the DNS network. We haven’t released any new changes to the domain linking workflow that should affect the speed of domain linking.

However, we have found that there might be an issue with DNS providers other than Cloudflare that is creating issues when connecting to domains that are hosted on those DNS providers.

I understand, thank you.

We have identified the issue and will be posting updates here: Custom domains fail to connect

1 Like

Hi there, I noticed that the dns flattening thing has been flagged as resolved, but this is depite the fact that my site cannot be rendered outside of replit webview. Thank you!

In the resolution note, we noted that we are still investigating the issue, but we have closed the incident as it is no longer categorized as such internally

I see, i apologize. Thank you very much!

Also, It would seem some of my other repls are suddenly dying, while this it should not be classed as an DNS related issue like some (this is the www. mirror that should be working fine), it has suddenly died.

I checked some things on the status site and it would seem nothing is wrong.

Both websites, the www and main one, work fine on our end. Are you still seeing the issues you reported? If so, can you please send us a screenshot of the issue so we can get an idea of what this looks like on your end?

1 Like

I was adviced to switch clusters and it worked. On the asian cluster the webview could render it. I will be creating another accoumt to try to replicate it.

1 Like