Repository disappeared

Bug description:

I had a personal repository, I always accessed it through the link redacoes.devioney.repl.co, however, after updating the platform I couldn’t access it and the repository disappeared. and unfortunately I don’t have a backup

Expected vs Current Behavior:

Steps to reproduce:

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Linux; Android 10; K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/117.0.0.0 Mobile Safari/537.36

Replit Profile: https://replit.com/@Devioney

:wave: Welcome @Devioney!

It seems this Repl has been deleted. You can restore it like so:

1. Go to the CLUI(that’s the link)

image

2. Go to :wastebasket: trash

3. Go to restore-repl

4. Enter the name of the Repl

Note that a helpful list of recently deleted Repl names pop up so it’s easier for you. In this case, you should look for “redacoes”.

You can also go to ~/cli/trash/restore-repl for a direct link to the restore-repl button.

I did the step by step and I still couldn’t recover my repository, I didn’t delete it, it simply disappeared from my account.

1 Like

@Devioney The link for it is actually quite helpful as it gives me the Repl ID which I can look up in our logs. The bad news is that it shows this Repl deleted on January 18th 2024. That would be past the retention period where you can recover it from the CLUI.

3 Likes

I understand, however I didn’t make the request to delete the repository, wouldn’t there be some way to restore it?