Replit webview not working

I can’t access the webview for any web-development Repls. Does anyone know what the issue may be?
Screenshot 2022-09-29 8.38.37 AM

Hey @FutureAxolotl welcome to the forums.

Can you please send us a link to the repl?

How would I go about that without getting flagged?

@FutureAxolotl It looks like you are posting join links to a repl. That lets anybody edit the code. So we made it so it automatically gets flagged when that happens. Can you please share a link to the cover page instead? Don’t worry you are not in trouble though. Just try and remember for the future.

I moved the posts to a private topic so nobody would do anything bad to the code.

Hi,

I did some digging and found it here:

https://replit.com/@FutureAxolotl/Making-a-ui-maybe?v=1

I just forked the Repl @FutureAxolotl and clicked Run and saw this:

Can you please check again and let me know if it now works? There was some Replit downtime earlier today so maybe this was the cause?

1 Like

I still get the page that says that it may have been moved to a new address. I’m wondering if it could be because of the firewall of my organization (I’m a student not using this commercially btw)?

Try to add a freenom domain, I had this problem, and using a free domain seemed to work.

I tried to get a domain from Freenom, but all of them said unavailable, no matter what the domain was.

Hi @FutureAxolotl quite possibly. If you can somehow try the Repl outside of your organisation e.g. a coffee shop and let me know if you still see the same issue it would be appreciated.

If you are still seeing the error I would definitely click on the ? icon bottom left of any Repl and then click Report a Bug so that Replit Support can log and investigate further.

I have tried it on my home network and it worked just fine, so I guess it is just the firewall of my organization.

Agreed, it sounds like it’s your org’s firewall. Give firewalledreplit.com a try! It works just like the usual Replit site and you can access your account and repls all the same, but without specific features that sometimes require schools to block the core Replit site. You can read more about it here.

2 Likes

Yeah, with firewalledreplit, the webview is just a blank screen.

Oh wait, I can just go the url using my web browser and it works. Problem solved finally!

1 Like

You must create an account, then freenom will allow you to get free domain.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.