Replit stuck on opening files and times out

I’ve recently encountered a problem with being able to open my replits from my desktop or laptop. This appears to be similar behavior to the problems described in help threads last october, so I was wondering what the outcome/resolution was and if there are any steps I can take to resolve this issue. None of the replits seem to work from my desktop or laptop (existing or new). Example https://replit.com/@kroberts100/hotel. The following link is to a HAR file illustrating that somewhere along the process a socket or connection with replit is timing out/failing: replit.com.har - Google Drive . Any insights or direction on resolving the issue would be appreciated.

  1. I can log in.
  2. I can see all my replits
  3. opening a replit shows the files greyed out and an indication of “working”.
  4. I ultimately end up with a “You are disconnected - Your connection to the server has been lost…” message.
  5. Happens under different browsers (chrome, edge, firefox)
  6. Clearing the browser’s cache doesn’t do anything either
  7. I’ve tried shutting down the firewall on both the router and the computer with no apparent difference.
  8. Is there some kind of contention for a port on the computer? What ports if any should I “reserve” for replit?
  9. Is there any replit address I should ping or tracert to verify connectivity? I can access my account and see the list of replits, bt cannot open one.
  10. Operating systems: Windows 10 & 11.
  11. Recently upgraded from a free account to replit core (may be coincidence)
  12. Mayday - I use replit to teach class and this problem is totally messing me and my classes up.

Hi @kroberts100 I think you submitted a ticket to us already, and it seems like it works great on a new computer that you have. In general, looking at the Repl, we’re not seeing any issues.

It sounds like you’re doing everything right to troubleshoot. Have you tried flushing the DNS? Do you use a VPN?

I’d also recommend comparing the differences between your new computer and the others that are not working.

I just tried flushing the DNS (no difference – good idea though). I do not use a vpn. I was hoping maybe there was something that could be gleamed from the problem others had a few months ago. There appears to be a socket that is not connecting. Do you have any knowledge of what that socket is trying to connect to? IP address/URL? Internal/external socket?

Thanks for your time,