Replit stuck in "loading" or "booting replit"

Problem description:
My Replit is stuck in “Loading” or “Booting” for half an hour. (
I tried reloading a couple of times

Expected behavior:
I guess it should be accessible

Actual behavior:
It is not accessable

Steps to reproduce:

Bug appears at this link:

Device (Android, iOS, n/a leave blank):
Plan (Free, Hacker, Pro Plan):

Hey @ChristophFahle , welcome to the forums!
Can you press CTRL+SHIFT+R when in the loading page?
This will refresh the repl’s cache.
If that doesn’t work, can you try forking the repl and see if the forked version works?

Same happening with me. Also a Python Replit.

Tried accessing through Replit Desktop (Windows 11), Replit App (iOS 17), and directly through the web - none of them loads as expected even after passing many minutes.

Tried CTRL+SHIFT+R, but didn’t worked.

Hi @kevinqz , welcome back!
Could you try the forking suggestion?

1 Like

Hey @NateDhaliwal, thanks!

It’s not feasible for me at the moment since all my environment secrets are stored in my Replit and inaccessible as well.

IIRC, if you have edit access to a Repl, Secrets are copied over as well. (It’s a new-ish change)


LOL, it worked! Didn’t knew about this release!

Thanks, @NateDhaliwal and @Firepup650!


Hey @ChristophFahle!

Thank you for reporting this. I was able to reproduce the issue and have sent this to the team. Keep an eye on this topic for updates on the issue.

same happening to me, replit desktop stuck loading.

Hey @ChristophFahle!

Are you still seeing the issue you reported?

Can you send me the link or name of the Repl that you are trying to view in the Desktop app? Also, if you view the Repl on (in the browser), do you run into the same issue?